3

I have TP Link TD-W8968 wireless router.

I can connect my laptop to the router but not a phone since few days.

I am facing a problem since a week, when I turn a wi-fi on on my android device HTC Wildfire S and scan for wifi, phone doesn't show up my router in scanned list, by the way it shows other wi-fis in the list but not my one.

I guess there could be some problem in my router. How can I solve this?

1

Improvement on previous Answer: Well i do partially agree with @Divin3 only a slight glitch i found was: All new routers are fully backward compatible with older devices hence a router built on Wireless-N will be fully compatabile with device capable of receiving only Wireless-G or older version. Difference will be that while serving to a device with W-G the router built on W-N will go only be able to serve it at the max bandwidth which is device W-G is capable of receiving. Read more details on a device manufacturer support site here

My Addon to the Previous Answer: Now lets back on the question, my very own personal experience has been bit different in this case. Sometimes older devices aren't able to scan WiFi networks setup with newer security methods. I noticed this when i switched one of my router's security from WEP to WPA2. Few older devices which earlier used to stay latched to the same router, actually stopped identifying it.

So a little bit of workaround could help people facing issues related to this.

0

This issue might occur if your router and the network adapter in your PC might not work together.

To work, the network adapter in your PC must use a wireless standard that is equal to or older than the router’s wireless standard. For example, if the network adapter in your PC uses the 802.11n wireless standard (also called Wireless-N) but your router uses 802.11g (also called Wireless-G), you won't be able to connect because the Wireless-G standard is an earlier version and doesn’t recognize Wireless-N. However, if the router uses Wireless-N but the adapter in your PC uses Wireless-G, you should be able to connect if the router is set to mixed mode.

Source:
http://answers.microsoft.com/en-us/windows/forum/windows8_1-networking/can-see-other-ssids-on-my-laptop-but-i-cant/f38b08d0-4bf4-4244-bbe7-0081d458bb2c

In other words, try to set your router to mixed mode and your phone to 802.11b/g compatible. That should do the trick.

0

My TP-Link router is a dual band router (2.4 and 5.0). If both bands have the same name, your phone may be confused. I gave each band (2.4 and 5) a different name. My phone can see both bands. I can now setup access to either band.

0

Problem: PC was able to connect to WIFI but my mobile ( android 6.1) was not able to obtain the IP address from TPlink Router.

Solution: Disable ' Enable Short GI', which is used for high data rate. But wifi adaptor in mobile is not able to obtain IP address due to this short Guard time.

How to Do: To disable this option, Go to Router home page - Wireless Advanced - Disable ' Enable Short GI'.

0

The phone or tablet in use may not support the Wi-Fi channel number specified by that TP-Link router.

Try changing the channel number and see if it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.