Today my Nexus 5 turned itself off, and then whenever I try to start it again, it loops rebooting - it shows the google logo, then starts the boot animation, then powers off and starts over.

I've tried to get into recovery mode with the volume+power keys, but when I'm able to get into the recovery screen, it shuts off in about the same amount of time and reboots again.

What can I do to fix this?

I did run the upgrade to 5.1.1, but it was a few days ago so I'm not sure whether that would be related.

  • Does download mode work?
    – Nikola K.
    Commented May 31, 2015 at 23:19
  • @NikolaK. Only Samsung devices have download mode. Daenyth, can you boot to fastboot?
    – Thomas Vos
    Commented Jun 1, 2015 at 12:32
  • @SuperThomasLab All devices have download mode.
    – Nikola K.
    Commented Jun 2, 2015 at 17:22

5 Answers 5


I think you encountered the issue with a stuck power button. I had the exact same behaviour that also went away without explanation to return a few weeks later. I read the one trick is to bang it in a hard surface and shock the button out of its stuck state.

The second time it occurred I actually found a much more gentle way to temporarily fix this. Take an electric tooth brush without brush and push the oscillating shaft onto the backside and side of the phone close to the power button. After a few seconds of that my phone was back in working order.

And I felt strangely like Mc Gywer.

*Update: This temporary fix still works two months later. So it was not so temporary considering the lifecycle of a modern smartphone.

*Update 2: This fix worked fore a few years. Now the Nexus is permanently stuck in a reboot loop and no toothbrushes or other vibrating tools will fix it.

  • 1
    I dunno, sounds more like you forced it out with a sonic screwdriver to me. ;)
    – Amber
    Commented Sep 24, 2015 at 17:52
  • Nice answer, put me on the right track. For me to deal with the stuck button was pressing it rapidly for a minute or so until the boot continued.
    – 4e6
    Commented Jan 13, 2016 at 7:19
  • @4e6 rapidly pressing the power button during boot does get it booted all the way, but as soon as I let go it reboots again.
    – Dennis
    Commented Feb 4, 2017 at 12:18
  • If you don't have an electric toothbrush, you can ask McGyver's girlfriend for something that "vibrates" (ahem). It really works!
    – bernie
    Commented Jan 17, 2018 at 0:39

On an earlier version of Lollipop, after an update, my Nexus 5 would turn off randomly and enter a boot loop. I tried entering recovery just as you did but it too kept rebooting. I researched reasons for a boot loop and discovered some users of the Nexus 5 have faulty power buttons.

Try repeatedly tapping the power button as if to get it unstuck. See if the boot loop stops because of this action. If it stops, carefully hold your N5 so that the power button does not get stuck and turn on your phone. Perhaps jiggle the phone a little after the long press to ensure the button jiggles too.

It sounds simple but this reliably booted my phone when it had troubles. I installed Gravity Screen (free in Google Play) and try my best not to use the power button. I have not had many troubles since and am on a long streak for no issues.

I mention it happening after an update but I would guess the issue is just coincidental with the update. Best of luck.


Try going into fastboot mode. Its comparatively much easier to go into fastboot mode. To go into fastboot mode, turn off your phone and press and hold volume down + power keys at same time until you get to a black screen with android logo and a bunch of stuff written.

Now there you also have option to boot into recovery, just press volume buttons to switch to boot modes and when it says recovery, press power button to select boot into recovery option.

Possibility 1:

You were able to go into recovery.

Here you can also try to factory reset and boot your phone. If that doesn't work, proceed below.

Case 1:

You have the rom to flash inside your phone (sdcard).

if you do have rom inside phone then just wipe system, cache, dalvic and if rom isnt same as the once currently installed on your phone (the one that is bootlooping), then you also need to wipe data.

Case 2:

You were able to boot into recovery but dont have any rom inside phone to flash.

  • In this case, setup ADB, connect phone while its in recovery to adb.

  • Download a rom for your phone (you can head over to XDA to look for rom and download one you like). Just download it to your pc.

  • Connect your phone to pc using USB.

  • Open cmd and enter the command adb push PathAndNameOfROMFile.zip /sdcard/. This will push the rom file you downloaded above to sdcard.

  • Wipe your system, dalvic cache, cache and data (recommended, but not necessary if you downloaded same rom as previously installed on your phone).

  • Reboot.

Possibility 2:

You were unable to go to recovery due to whatever reason.

Boot into fastboot mode again.

Option 1:

Try wiping data and factory resetting from here (I wont be responsible for your data here).

  • To factory reset, first setup adb from link provided above. Then go to download mode and connect phone to pc.

  • Open CMD/Terminal. And enter these commands:

fastboot erase data fastboot erase cache

Now try rebooting. If that didn't work, move on to Option 2.

Option 2:

(We are going to flash a factory image.)

  • So first, download factory image for your phone here.

  • Extract downloaded archive using winrar.

  • Connect your phone to pc using USB.

  • Execute the flash-all.bat script (for Windows) or flash-all.sh(for MAC and LINUX) in the folder where you extracted the factory images.


For MAC: You'll have to edit the flash-all.sh, and add "./" before every fastboot command.

This script will also flash stock recovery. If you are not sure that your recovery is ok, then let this happen. Otherwise if you are sure that your recovery is fine and not corrupt. delete the file with word recovery in it. Open and edit whatever flash script you will be using to flash and remove these lines:

fastboot erase recovery
fastboot flash recovery recovery.img

Semi-Case 1:

Everything flashes fine.

In this case just skip the Semi-Case 2 and move on.

Semi-Case 2:

There is some problem flashing some specific part.

In this case, you can try flashing manually.

Run these commands One by One in cmd/terminal (replace C:/ with path to where you extracted the archive):

fastboot flash bootloader C:/image-hammerhead-xxxx/bootloader.img
fastboot reboot-bootloader
fastboot flash radio C:/image-hammerhead-xxxx/radio.img
fastboot reboot-bootloader
fastboot flash system C:/image-hammerhead-xxxxx/system.img
fastboot flash userdata C:/image-hammerhead-xxxxx/userdata.img 
(Note: this command will wipe your device (including /sdcard), EVEN if your bootloader is already unlocked.)

fastboot flash boot C:/image-hammerhead-xxxx/boot.img

fastboot flash recovery C:/image-hammerhead-xxxx/recovery.img
(Skip the above command if you dont want to flash stock recovery and are sure that your current recovery is not corrupt).

fastboot erase cache

This will manually flash everything. Hopefully this time it should be fine.

  • Wait for everything to flash.

  • After everything has finished flashing, use volume buttons to select recovery option from fastboot and press power button to boot into it.

  • Select factory reset and reboot phone. You will turn on and you although are still rooted (just need to install a custom recovery and supersu from play store).

Hope this helps.

  • 1
    Hey! That's very detailed and useful. Covers most of the part except that it is yet not clear whether OP's device is unlocked or not. (Recovery part perhaps won't work as the device reboots itself in Recovery too (as mentioned in question).) If it is unlocked than cool! If not, then warranty I guess will be void as well as data will be lost. But +1 for your work.
    – Firelord
    Commented Jun 1, 2015 at 13:22

There are a number of long winded threads on the Nexus product forums about this. Some people get resolution by replacing or fixing the power button, as noted already here. Others by replacing the battery, others by sending to LG for replacement. I saw at least two reports of cures by rooting and going to an older kernel (5.0, 5.1).

The fact that so many of the reports cluster around 5.1.1 update make me suspicious that the hardware approach (button, battery) address the true problem, but hey if it lets you get another few months or year out of the device go for it.

For me my phone seems be fixed (only 24 hours free and clear so far), but I don't know what the magic was. What I did follows, the presence of next step indicates the previous one didn't work (phone still rebooted or shutdown spontaneously).

  • Reset to factory default using Settings menu
  • Reset to factory defaults using Recover Mode in bootloader
  • Use WugFresh Nexus Root Kit to unlock bootloader, root the phone
  • WugFresh revert: Flash stock image and unroot (which uses the most recent official 5.1.1 image)

At this point the phone finally stabilized, going ~15 hours without a reboot or shutdown.

In the middle I talked to Google and LG customer service, I'll add details of that to another answer. Since I'm so deep in now I've since re-unlocked and rooted and applied PureNexus ROM and GAPPS. So far so good, but it's only been a few hours.

**Update: celebration was premature. Phone is still rebooting, though frequency has diminished. Looks like I go back to stock and wait much longer before trying anything else, including reinstalling most used apps. :-( **


  • I think mine was a legitimate hardware error because even the boot loader was inaccessible.
    – Daenyth
    Commented Sep 17, 2015 at 18:32
  • @Daenyth that also may be why they would fix yours out of warranty but not mine. I added to the thread even though your issue has been solved because of the title, and there are sooo many others reporting similar problem, but it's hard to get the info out of the rambling threads. Commented Sep 17, 2015 at 18:44

In the end, nothing I tried worked - it went into the reboot loop even from inside the boot loader screen, so I couldn't get into recovery mode.

I sent it to LG and they repaired it for free even though it was supposed to be out of warranty.

  • I used Get a call from a Nexus Support Specialist. Talked to Google rep, who was very good, was transferred to an LG, then again to a LG Canada (888-542-2623). My phone is also out of warranty. For a fixed price of $150 I can ship to them and have fixed. 5-10 business day round trip. Afterwards there is a 90 day warranty, that only applies to the reported issue. Commented Sep 17, 2015 at 18:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .