4

Xiaomi redmi 2 runs MIUI 6.2.4.0(KHJCNBK)

In order to install CWM, I downloaded both the adb and fastboot, I extracted recovery.img in the folder, together with them. I entered fastboot mode.

Then, in fastboot I ran:

fastboot flash recovery recovery.img

fastboot reboot

Now I booted CWM into recovery. It I ran this superuser file, which matches my phone model. It installed, had done! at the end:

enter image description here However, when I exit the menu it asks me whether to root the phone ( with root access is missing at the top ), I tried both yes/no, it reboots, but phone is still not rooted. What's the issue here?

3
  • 2
    Its rooted, and that prompt (it appears only when the supersu isnt properly installed, like its binaries). So, there might be some problem with supersu binaries. I suggest you turn on phone and then verify root and supersu status. Get some app from play store like root checker and see how that does too Jun 1, 2015 at 6:59
  • 1
    Have you tried booting your device normally and running the SuperUser app? As Jaskaranbir suggests, it might need to update some of its binaries (especially the su binary requires this sometimes). If you do so, keep your eyes open for any possible error messages and, if there are some, edit your question and include them. Thanks, and good luck!
    – Izzy
    Jun 1, 2015 at 7:06
  • Just installed the .apk from superuserdownload.com. Runs fine, but the "apps" tab is empty. My objective is to clear factory apps, that's all.
    – T. Dimoff
    Jun 2, 2015 at 8:54

1 Answer 1

1

You did succesfully installed the superuser framework but you need to install SuperSu what controls everything. Follow steps below to successfully install SuperSu:

  1. Download SuperSu from the play store here.
  2. Open SuperSu and you should see something like this:

update su binary

Screenshot - Update SU binary (Click to enlarge)

  1. Click continue.
  2. Click normal. (If you see message for more then 5 minutes then reboot and try the other option)
  3. Reboot your phone and now you should be rooted. Check it with a root checker app like this:

root check, success

ScreenShot - Root check, Success (Click to enlarge)

  1. Consider purchasing the pro version to support the developer here.

Hope my answer helps.

6
  • @Firelord I added more info.
    – Thomas Vos
    Jun 1, 2015 at 12:20
  • I get there is no SU binary installed, and SuperSU cannot install it When attempting to run the app.
    – T. Dimoff
    Jun 1, 2015 at 14:33
  • @StevenHaen Then there was a problem installing the SU binary, you should reinstall the su binary and select yes when it gives the message yourbphone may not be rooted etc. Then follow my steps again.
    – Thomas Vos
    Jun 1, 2015 at 14:35
  • When I click normal it spits back update failed. When I try to use my CWM it displays will try to reboot device and then nothing happens.
    – T. Dimoff
    Jun 2, 2015 at 21:58
  • Then reboot your device and try again
    – Thomas Vos
    Jun 3, 2015 at 7:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .