This question is the next part of this question. I'm trying to use find command (Android 4.2.1; Busybox installed, have root access) to list files owned by a specific group under /, but every time I use it I get the same reply. E.g. I'm trying to find all the files owned by group adb using find / -group adb and the output says:

find: unknown group adb

I tried both single-double quotes but no effect. Tried for other groups but no effect again.

How should I use find then?


The method of using find is correct.

However there is no group "adb".

Run id -p to get all groups. You will get


Then run find / -group <groupid>.

The groupid is an integer.

| improve this answer | |
  • +1. It works. I was just focusing on the name considering this -group NAME/ID File is owned by given group while it was supposed to be ID that needed to be passed. Could you mention what would be passed as NAME? – user109933 Jun 2 '15 at 1:11
  • Could you also take a look at a similar questions here? That would be very helpful. – user109933 Jun 2 '15 at 1:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy