1

I filed this as an Android bug (AOSP Issue #175555) and somebody recommended posting here. I'm actually not sure it's appropriate to post this here but I'll give it a shot.

  1. Get into a car a passenger.
  2. Open your laptop and plug in your phone.
  3. Watch logcat
  4. Ask the driver to make their way to the freeway using a route that take more than 5 minutes.

Roughly, after about 5 minutes the phone will disconnect from ADB. Unplugging the phone and plugging it back in, the phone will reconnect but disconnect. Maybe it's an illusion but it seems the faster the car is driving, the quicker it will disconnect.

I've tested this with an HTC One M7 and a OnePlus One. If the OnePlus is not involved, the HTC always seems to be able to reconnected. However, once the OnePlus can't connect enough times, nothing can connect, not even the HTC One. The OnePlus seems to "poison the well" as it were.

I've tried several different USB cables and ports on two computers, a Macbook Pro and a Lenovo Yoga. I'll be on a road trip this summer and can debugging more with a third phone.

If there are any tools that I can use or commands I can run to help debug this issue, please advise and I'll use them the next time I'm debugging my app in the car.

Lastly, sometimes my OnePlus disconnects while on my desk but it's far less frequent and usually only after a long period of not being used.

  • We don't really accept bug report since we can't do anything to fix the cause, but perhaps this is not a bug but a hardware issue, which is on-topic here. I still doubt if the "inside the car" is related and intensifies the issue, but I never try that, so I can't comment. If it's related, then it makes this issue very interesting though. I'd suspect loose USB host, but it doesn't seem to explain why "the faster the car is driving, the quicker it will disconnect". – Andrew T. Jun 3 '15 at 5:58
  • Which CM version are you running on OnePlus One? I've this seen this irritating problem in CM12? – Firelord Jun 3 '15 at 8:39
  • @Firelord, I experienced this on CM11 and have not had the opportunity to reproduce on CM12, yet. – Dave Jensen Jun 3 '15 at 19:23
0

Since you are sure that its not a port/USB wire issue and since ADB does detect phone, its not a driver issue either. Hence saying what the real problem is likely not really possible to be accurately predicted. ADB is a very "delicate" stuff. A slight connection problem causes disconnects... My best bet here would be loose connections. You should certainly try with other computers if you can.

For timebeing, there is one thing you can try if you debug while phone is on (and not in recovery or fastboot mode), ADB through wireless. Like using your wifi for adb. The adb client will be on your laptop and you can issue commands just like normal to phone through your laptop. Although modern ROMs have inbuilt option for this called ADB over wireless which you can find under settings->developer options. But in case you dont have that option, you can also use third party apps that allow you to do so like ADB Konnect.

Just install and open any such app and it should give you an address according to wifi/network you are connected to. Lets say it gives you 123.456.7.8.

Then open CMD/Terminal in laptop and use the command adb connect 123.456.7.8 to get connected to adb. Then you can issue all your commands as normal.

The downside is that your phone Has to be on. So in recovery/fastboot etc, you cant work using this.

  • I did try with other computers and different cables, but the issue persists with OnePlus One only. Ultimately, I ended up using SSH shell to access my device. – Firelord Jun 3 '15 at 8:41
  • I updated the question. I forgot that I tried this on two different computers. – Dave Jensen Jun 3 '15 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.