0

I have an android device (YotaPhone 2 actually) that is in continuously rebooting state with android logo showing on main screen.

When phone wasn't bricked then was possible to boot into official recovery with usual combination of buttons during startup. After bricking it is impossible to boot into recovery. But still possible to boot to "Downloading" state.

There is no alternative firmware or recovery. They haven't open source of kernel yet, so no CyanogenMod (or something similar) for my device. And therefore no custom recovery (except official one).

  1. I tried to flash several official firmwares (from this ftp) with official windows flasher (which off course based on fastboot). No result, still android logo and continuously rebooting.
  2. I tried to use fastboot and flash only recovery. No result.
  3. I tried to erase boot and force booting to recovery. No success.

What else ways do I have to unbrick my device?

P.S. Warranty repair isn't an option because I dropped it onto concrete floor and damaged both screens (LCD one and Eink one).

P.P.S. Payment repair also isn't an option because it costs almost as much as new phone in my case.

  • About 3., are you certain fastboot erased boot successfully? If there is no boot then how is your phone still rebooting; it shouldn't be at least showing the Android logo. // This is bit dirty but if you can use still fastboot and have access to fastboot type ROM then erase system, boot, userdata, cache, and recovery partitions through it. Flash them again and see what happens. Did you mean you flash them already when you said about firmware? Did you try other Android versions from that FTP? Note that your data will be lost but it seems your priority is to unbrick only. – Firelord Jun 3 '15 at 15:33
  • 1
    Speaking about which: if you don't care for the data on the device, a factory-reset might be an option: fastboot -w (wipe cache and all user-data). – Izzy Jun 3 '15 at 15:58

protected by Community Jul 16 '17 at 21:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.