I am having this weird problem with my Vega Iron since a couple of days. Past 2 days the battery was down and phone shut off. I put it to charging and when I came back after couple of hours, the led indicated green and I pulled it out of charging and powered on. Since then, the phone is not working normal.

  • It does not show/connect to cell network, thus cannot call or sms
  • If I try to go to mobile network settings option, the phone hangs (white blank page then black blank page) and I can only manage to get away by using task manager (after pressing back and home keys few times, it shows me the recent tasks where I can close the settings page)
  • The phone hangs every now and then. For e.g. if I hit power once to close the display, then hit again to open, it takes couple of minutes before it can come back to life
  • I tried the phone secret info menu *#*#4636#*#* then "Phone information", but the same happens and it hangs.
  • I tried the secret UMTS menu (##7593#), and it opens with a message "ril socket is not available", if I click the network option (that sets automatic/wcdma/gsm/etc) then same message that ril socket is not available

I tried all this:

  • Phone restart
  • Batter removed and then put in again
  • Sim card and SD card removed
  • Airplane mode turned on (even on airplane mode, the phone hangs)
  • Factory reset

The phone battery drains very quick and gets hot as well. I guess phone trying to access RILD again and again.

Is there some way this can be fixed, or at least the RIL call events be shut down? Could the phone be set to work without radio?

  • I took my phone to some firmware flash experts, and I found out there that the baseband is not showing up. Means when I go to the About phone menu, it shows "unknow" for Baseband. I could not reach the "Status" option but I am sure that IMEI is also gone, as I can see on many forums that people say that baseband and IMEI is related and lost together. Commented Jun 5, 2015 at 23:50
  • Forums suggest to use MTK Droid tool to restore IMEI but the IMEI/NVRAM button is not enabled when I connect my phone to the tool. Also one weird thing is that I cannot find any nvram folder in my phone. Commented Jun 5, 2015 at 23:52

1 Answer 1


Finally I found the answer to my problem!

I took my phone to another expert and he told me that the Baseband IC is gone and it is a hardware problem. He could fix it if I can get him the IC as it is not available in our markets because of being a rarely used korean phone.

This thing is confirmed by another forum post here: http://forum.xda-developers.com/showpost.php?p=26827676&postcount=4512%22

where they say:

type *#06# , and IF you get message "imei null" or imei starts by 0049XXXX or 00000 it should be resolved by software . but IF nothing is shown when you type *#06#, that is a hardware problem or look at attached picture below. .

When I dial this code on my phone, nothing happens, so it confirms that it is a hardware problem.

I will try to get the hardware component somehow and see if it works.

My actual problem is not solved but I got answers and atleast I am comfortable that I given it a try!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .