I'm trying to get tethering to work. I've used the built-in functionality, setup my phone as an AP and connected to the wireless network.

I get an IP ( and I can ping the gateway (, I also got a dns server ( However, I can't access the internet (e.g. surf or ping

Any ideas on what may be wrong?

netstat -r (restricted to en1, the wireless interface)

Destination        Gateway            Flags        Refs      Use   Netif Expire
default         UGScI           0        0     en1
192.168.43         link#6             UCS             2        0     en1       4:18:f:40:41:7c    UHLWI           0       16     en1    925     ff:ff:ff:ff:ff:ff  UHLWbI          0       12     en1

Some more info

  • Using WPA2 Personal (since I can ping the phone/gateway/router I should be beyond the encryption layer in the OSI model, so I don't think encryption is the problem)
  • Wireless AP
  • No third-party tethering (using native)
  • Samsung Galaxy
  • No custom ROM
  • Don't know if it's rooted (I guess the fact that I don't know means it isn't)
  • What do you mean by the router? The "router" should be the phone in this setup. Either way: Why is the address not What device do you have? Jul 4, 2011 at 14:42
  • The router is OS X language for gateway (updated the question). The device is a Samsung Galaxy Gio (not locked to a particular carrier).
    – sandstrom
    Jul 4, 2011 at 20:22
  • I believe what you are trying to do is impossible because of android.stackexchange.com/a/14788/8059
    – Gili
    Jul 9, 2012 at 18:41

2 Answers 2


If you are on linux, check up the kernel routing table by typing route at terminal.

if you do not have a default entry in the list it won't work. For example my kernel routing table reads:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface   *        U     2      0        0 eth1
link-local      *          U     1000   0        0 eth1
default         UG    0      0        0 eth1

Type in this command at terminal and see if it works:

sudo route add default gw wlan0

where wlan0 is your wireless interface....

also you could try rechecking the dns server on your machine and add the following lines to your etc/resolv.conf

  • Thanks! I've added a routing table. The DNS shouldn't be the problem since I can't even ping public IPs (such as
    – sandstrom
    Jul 5, 2011 at 15:49

Let's clear up some terminologies here:

  1. The phone acts is both a gateway (translates between Mobile network protocol and Wifi protocol) and a router (routes packets to and from other devices and the external link). I assume that your phone's IP address is The phone have an internet connection through mobile data connection and want to share this connection with other devices.
  2. The other devices (e.g. laptop) does not have direct internet connection, and is trying to tether through the gateway/phone. In your case, the other devices acquired the IP through DHCP.

Are you using any encryption? WEP or WPA? I suggests setting up an open network for troubleshooting, and only setup encryption after you are able to connect through unencrypted connection. Check that the encryption setting and passphrase matches.

What tethering method are you using? Are you using third party tethering, e.g. PDANet or android-wifi-tether? or are you using the native tethering in Android 2.2 and up?

What phone? Is it custom ROM? Is it rooted?

  • Yes, good clarification on the terminology! I've added some more information at the top, to answer your questions.
    – sandstrom
    Aug 18, 2011 at 13:23
  • Better to ask clarification questions as comments on the original question. It's hard to find the answer in here.
    – ale
    Aug 18, 2011 at 14:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .