My phone currently synchronizes the contacts with my personal Google account. I would like to change that so it would synchronize the contacts with an other account of mine. I added the other account, but in the synchronization settings it's empty. I can't see the same options that I see in my personal account's settings. (My personal account contains Gmail, Google Calendar, and Contacts... there isn't Gmail and Calendar associated with my other account, so don't seeing it might be expected, but it definitely has Contacts.)

What can possibly cause this? Is there a way to still make the synchronization happen that way?

(I use Sony Ericsson Xperia X10 mini pro with Android 2.1, and I don't want to root my phone and load a custom ROM yet.)

1 Answer 1


I think Press Menu > Settings > Accounts and Sync > and Select the Account > then it should Display Options with checkBoxes like Calender, Contacts, Email... Thats what I have got in my Phone Running Froyo Good Luck

  • As the question states, there isn't any of this there in my case.
    – ytg
    Commented Jul 4, 2011 at 13:54
  • You will still see contacts, and gmail, in the account sync. Those items are there even if they aren't "associated" with any of the actual services. Picasa is the only service I have seen that doesn't actually show up, unless you actually use picasa with the account. All of my accounts show Google Reader, Books, etc, and I only use those services on one account. Commented Jul 4, 2011 at 16:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .