1

I've been trying all I can too root my phone but I have problems when installing the SU to the /system/bin (or xbin, don't really remember).

I used TWR in recovery mode to install the 'superuser' and it shows a blue 'Successful' message, then it asks to install the 'SuperUS' to gain root access, I obviously swipe yes and it just reboots but just when it does that it shows for a split of a second a message in red saying 'E: failed to copy su binary to /system/bin (...) is read only' (couldn't read all the message since it reboots immediately)

I tried searching about this problem but it seems the only way to change the internal memory to read/write is by having root... But I can't even root because I have this problem... Using the 'fix permissions' on TWR doesn't help either.

Any help? Do I have to wait for a specific exploit or something?

Here's some info about my phone

  1. Moto G LTE x1040
  2. System version 21.31.1.peregrine.retla.retla.en.01 entcl
  3. Build: KXB21.14-L1.56-1
  4. OS: KitKat 4.4.4
  5. Unlocked Bootloader

I don't really want to install a custom ROM (they have root by default I think) since I just want root access since this is the first time I try to root so I fear that I could brick my device.

  • You should boot phone to fastboot, connect to PC and use adb to mount system rewritable and then sideload the zip. – Thomas Vos Jun 8 '15 at 13:57
  • The thing is, right now I tried using the adb command while in fastboot but it doesn't recognize the device being attached (error: device not found), but checking with 'fastboot devices' it properly shows my phone connected... adb detects my device but just when I'm not in fastboot mode x_x, I reinstalled the drivers but it still doesn't recognize the device in fastboot. As soon I get this fixed I will try your solution (mount /system to rewritable and sideload the .zip) – Shiraenei Jun 8 '15 at 15:27
  • EDIT: Can't fix this new problem :( I reinstalled the drivers but it still won't show the device on recovery mode to start adb sideload. EDIT 2: I managed to get adb to recognize my device when in recovery mode but when I choose ADB Sideload on TWRP I can't do the 'adb sideload SuperSU.zip' command because it says 'error: device not found' again :(. EDIT 3: Managed to make adb to recognize sideload on cmd but when I try to 'adb sideload SuperSU.zip' it returns the following message * failed to write data 'protocol fault <no status>' * – Shiraenei Jun 8 '15 at 23:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.