1

I've used Heimdall 1.4.0 on my mac to install CWM 6.0.4.3 (file name: recovery-clockwork-6.0.4.3-n7100) on my Samsung Note 2 GT-N7100 with android 4.3, the installation went smooth with no issues.

I then booted in recovery mode (volume up, home, power) and installed the zip file containing superuser downloaded from the link on the google play.

I then booted my phone normally, and tried if it was rooted with root checker, installed via google play. It says it's not rooted.

the application superuser starts and gives no errors,

I've done the procedure several times, also installing supersu, and installing other versions of CWM but I always got the same result.

What could I possibly have done wrong? and how can I finally get to root my phone?

thanks,

  • when you starting the SuperSu Apk app, Option (Root this phone) working? – ʍѳђઽ૯ท Jun 8 '15 at 12:38
  • 3
    First make sure the phone really is not rooted - the root checker might be wrong. Use a terminal app, execute su command and see what happens. If you're asked for root permission and the command executes, execute id command. It should say something like uid=0 or similar - the zero is important. – mikky Jun 8 '15 at 12:38
  • 2
    there is no sudo in Android, that's why I posted the exact commands you should try – mikky Jun 8 '15 at 12:45
  • you're right, I got confused.. I never use su :P. my id is: 10175 and it remains unchanged if I run id after su, but I get requested no permissions or anything – Don Giulio Jun 8 '15 at 12:46
  • Well, in that case your phone really isn't rooted. Or at least not fully. do a ls -l /system/xbin/su to see if at least the su binary is installed properly. If not, the problem is with the CWM-installed supersu zip or with CWM itself and would need different approach. – mikky Jun 8 '15 at 12:49
3

You are rooted. AFAIK Samsung bootloaders are already unlocked, you only need to flash the recovery to get the "root"

Now for the problem.

Go to settings->about phone and tap the build number 7 times to enable developer options. Then go to settings->developer options and there you should be an option similar to root access. Make sure you select Apps or Apps and ADB (recommended) in it and you should have root access.

If there is no such option, download and flash SuperSU via recovery and you should have root access later.

And that addition of "255|" in indicates you being in root user mode and accessing terminal as root. So its a positive sign here as well.

Alternatively, in case you failed to get the root to work, you can also flash some custom ROM like Cyanogenmod via recovery.

But rest assured, you are rooted. Its probably some bug and flashing supersu should probably fix it.

  • Thanks, I don't have any root option in the developer options, Which Supersu should I install? the instructions I followed include the 0.96, which didn't work, then I tried installing the 2.46 but it didn't work either – Don Giulio Jun 8 '15 at 13:01
  • 1
    try the latest, 2.94. Another thing, in terminal emulator run the command-> "ls /system/xbin" without quotes and tell me output if you can? – Jaskaranbir Singh Jun 8 '15 at 13:04
  • 1
    ok, the su file is the superuser binary or the root permissions in rough words. So supersu is properly installed. Check the supersu settings? It has an option to block root calls, make sure its disabled and default "Root access" is set to "Prompt" – Jaskaranbir Singh Jun 8 '15 at 13:08
  • 1
    First, dont select that "fix root" option in CMD again, that wont help. Second, it would have asked you to "Update *Binaries". So were you able to install them? You will have to install binaries to gain root, else root wont work.... – Jaskaranbir Singh Jun 8 '15 at 13:41
  • 1
    @JaskaranbirSingh "Besides you can only install custom recovery if you are rooted." Sure about that? AFAIK the only condition here is the device must be unlocked; if so, custom recovery can be flashed. Of course that depends on the device, so what you wrote might be valid for the Note 2 (which I cannot tell as I don't have one to check – but obvioulsy OP flashed CWM before getting root to work ;) – Izzy Jun 8 '15 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.