My Question is specific to copying the YouTube APK file from My Android device (Micromax Canvas 4 - Android 4.2, Non-rooted device)to PC/Laptop.

The YouTube App is a system app in my device. Below is the path for it.


I used adb shell pm path com.google.android.youtube command to find the exact path of YouTube APK.

I tried to use adb pull to copy the APK as below:

adb pull /system/app/YouTube.apk

This throw below error message:

remote object 'C:/Program Files (x86)/Git/system/app/YouTube.apk' does not exist

I am also fine if I can copy this APK to external SD-card which is mounted in my Android device (in case if I cannot adb pull it)

Any Hints?

Device Details:Micromax Canvas 4 (Android 4.2) Non-rooted device

  • Just in case... did you try using some file manager like ES Explorer or some backup app like "Assistant for Android"? They can backup the APKs from which you can extract youtube apk perhaps? Jun 9, 2015 at 6:09
  • @JaskaranbirSingh: Nope. I did not tried those options yet. The objective is to have YouTube Apk with current version with me, on my PC so that if in future if I want to downgrade, I use this SAVED APK. If you have experience of using ES Explorer or some backup app like "Assistant for Android, you may post links of their usage or post as your answer so that I (and may be others)can try! Jun 9, 2015 at 6:13
  • I'm confused. The error message looks the wrong way around (you are not pulling from Windows). Apart from that, your command lacks an argument: adb pull <src_on_Android_device> <target_on_computer> – e.g. adb pull /system/app/YouTube.apk YouTube.apk, so maybe that's the problem here?
    – Izzy
    Jun 9, 2015 at 6:55
  • @Izzy: Tried with command that you mentioned as-is. adb pull /system/app/YouTube.apk YouTube.apk, but still exact error that I posted earlier "remote object 'C:/Program Files (x86)/Git/system/app/YouTube.apk' does not exist". Just to clarify, I have android SDK (and adb tools etc.) installed at this location: C:\Users\myname\android-sdks\platform-tools and I am running adb commands using git-bash Shell program from Windows-7 PC Jun 9, 2015 at 7:03
  • Not sure what that git-bash Shell program is, but as the error states remote object, and names C:\.. as such, it looks like your PC is the remote and you're executing the command on the Android end. To verify my suspicion, could you try it the other way around: adb push /system/app/YouTube.apk "C:/Program Files (x86)/Git/system/app/YouTube.apk"?
    – Izzy
    Jun 9, 2015 at 7:07

1 Answer 1


(Comments Reference) Since your main motive is to get the APK file, we can try three approaches here:

1) Using a backup app: There are a lot of great backup apps like Titanium, but since its just as a temporary solution with only motive to get the APK file, I would suggest using a simpler backup app like Android Assisstant. Using this, we first backup Youtube APK and then we copy it to PC.

  • Open the app after downloading from above link.

  • Go to Tools->Backup and Restore

enter image description here

  • In the list, check-mark the YouTube.apkand press Backup.

  • The app APK would be saved in directory /sdcard/AndroidAssisstant_appbackup which you can transfer to PC normally.

2) Using a Root File Manager: Since we dont need to root for reading system, any root browser would work. For simplicity, I would recommend using Solid Explorer (since ES could be a bit too much for first-time users).

  • After installing Solid Explorer, open the app and press the Jump button at bottom panel and choose Device->System Root.

  • Browse over to /system/app and copy over Youtube.apk to sdcard. Transfer this file to PC through whatever methods you prefer.

NOTE: Trial version of solid explorer allows you to only open it once. So an alternative would be Root Browser which has a very similar interface.

3) Using Terminal Emulator: Download/Install Terminal Emulator.

Open the app and use the command cp /system/app/YouTube.apk /sdcard/which should copy the APK file to your sdcard that you can tranfer to PC normally.

Hope this helps.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .