My phone GT-S7582 does not start when powered on it only displays Samsung GALAXY S DUOS GT-S7582 and also it does not enter in to the download mode.

  • anything that worked ?
    – ABcDexter
    Jul 30, 2016 at 16:04
  • Try using Kies3, it's good and install samsung's firmware update!
    – ABcDexter
    Jul 30, 2016 at 21:36

1 Answer 1


I had the same problem for the past two days, tried many things like pressing Recovery mode(vol up+power button+Home), wiping the cache clear, reseting into factory mode, etc.

  • You should first install Kies3 on your PC and try again to go into the Download Mode (vol down+home+power button).
  • Then connect your phone to PC using USB cable. Oh, before that, you should write down your Phone model (GT-S7582 and Serial Number which is an alphanumeric code, behind your phone after you remove your battery.)
  • Then open Kies, go to Tools option, then Firmware upgrade and initialization and do as prompted in next few windows.
  • The download will start. Please make sure you don't disconnect the USB cable and You should have 3 GB of free space in your C: drive (in case your OS is Windows)
  • Everything will be rest and your phone will be as good as new. Use Google account's backup to restore apps and settings...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .