0

Alright, so this is an ongoing saga of trying to fix my broken SD card. Let me struggle to explain what's wrong with it.

When copying files to the SD card

The files are completely corrupted. For instance, have a listen to Body Talk by Robyn:

https://soundcloud.com/nobleuplift/sets/corrupted-body-talk

Some songs are mashups of other songs on my phone, or speed up to 4x speed. We Dance to the Beat takes 17 seconds to play.

When deleting files from the SD card

The files/folders will appear deleted up to the point either when the SD card is mounted/unmounted, reformatted, or the phone is restarted.

Yes, you heard me right, reformatting does not delete any data from my SD card. It is restored to the state it was in two weeks ago when I first noticed signs of corruption.

On the bright side, I can still listen to anything I copied to the SD card beforehand with no corruption.

When trying to reformat the SD card by other means

First, I tried to reformat the SD card using Windows XP. I tried both exFAT and NTFS. exFAT failed immediately, whereas NTFS took about 15 minutes before it said it couldn't do it.

I tried the exact same thing on my MacBook Pro and here are the logs from trying that:

===== Monday, 2015 June 8 at 11:43:24 PM Central Daylight Time =====
2015-06-08 23:43:34 -0500: Preparing to erase : “SD64GB”
2015-06-08 23:43:34 -0500:  Partition Scheme: Master Boot Record
2015-06-08 23:43:34 -0500:  1 volume will be created
2015-06-08 23:43:34 -0500:      Name        : “SD64GB”
2015-06-08 23:43:34 -0500:      Size        : 63.86 GB
2015-06-08 23:43:34 -0500:      File system : ExFAT

2015-06-08 23:43:34 -0500: Unmounting disk
2015-06-08 23:43:34 -0500: Creating the partition map
2015-06-08 23:43:34 -0500: Waiting for the disks to reappear
2015-06-08 23:43:34 -0500: Formatting disk2s1 as ExFAT with name SD64GB
2015-06-08 23:43:34 -0500: Reformatting existing ExFAT volume
Volume name      : SD64GB
Partition offset : 0 sectors (0 bytes)
Volume size      : 124733440 sectors (63863521280 bytes)
Bytes per sector : 512
Bytes per cluster: 131072
FAT offset       : 2048 sectors (1048576 bytes)
# FAT sectors    : 4096
Number of FATs   : 1
Cluster offset   : 6144 sectors (3145728 bytes)
# Clusters       : 487216
Volume Serial #  : 5bc0a34d
Bitmap start     : 2
Bitmap file size : 60902
Upcase start     : 3
Upcase file size : 5836
Root start       : 4

2015-06-08 23:43:34 -0500: Mounting disk
2015-06-08 23:43:34 -0500: Could not mount disk2s1 with name (null) after erase
2015-06-08 23:43:34 -0500: Erase complete.
2015-06-08 23:43:34 -0500: 

So... yeah... Anyone have any idea on how to fix this?

  • The card may very well be broken. If you have a linux or a mac handy, try dd or badblocks command to do an image of the card or scan it to see if any errors are detected. There are lots of how-to's on this topic. – mikky Jun 9 '15 at 16:03
  • Does the card have to be mounted to run those? When I tried to mount disk2s1, OS X told me it could not mount it. – NobleUplift Jun 9 '15 at 16:20
  • No, you don't. This is block-level operation while mounting is filesystem-level. – mikky Jun 9 '15 at 19:55
  • Alright, I'll try again using my MacBook when I get home. – NobleUplift Jun 9 '15 at 20:23
0

The solution was to send a support request to SanDisk, who told me to break the chip in half and then send it back to them since it is still under warranty.

http://kb.sandisk.com/app/ask/p/557,785,786,2158

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.