1

I rooted my device using the king root app and unrooted using king root as well my device is a titan hd e500 , I tried using root cloack , but it did not work I rooted again so I am rooted now , I resorted to downloading the first version of underworld empire from aptoide and that worked for a month but with a recent update its not possible to use older version now , when the app opens it says to install new version, I tried to may b find a way to change the older app version to the new one to make the app think its running the latest version.. Not possible. I am runing on version 4.4.2 KitKat

  • 1
    Not sure if that's a device dependent thing. Could you please edit your question once more and include your device name, the Android version it's running, the rooting method you'd used "back then", which superuser app was installed, and how you've "unrooted"? – Izzy Jun 10 '15 at 15:22
  • What game is this? – Matthew Read Jun 10 '15 at 15:24
  • @MatthewRead Related question: android.stackexchange.com/questions/112004/… – rink.attendant.6 Jun 10 '15 at 15:24
  • The game is Underworld empire – ZION Jun 10 '15 at 15:26
  • @ZION please check my updated answer again. The "Root Hider" list I've referenced I'm currently updating, so in a few minutes there could be some more you could try. – Izzy Jun 10 '15 at 15:40
1

Assuming this is an XY problem, and the real issue is that you want to play that game:

If your device is still rooted, you could install the Xposed Framework and its Root Cloak module, which hides root from specific apps. There might be other root-hiders as well, so it cannot hurt to search (or to check in my Root Hider list ;).

For more details on the Xposed Framework and what you can do with it, you're welcome taking a look at my Collection of Xposed resources.

In the worst case, if you really need to unroot your device: SuperSU offers to do that for you. If you're using a different superuser app, there are possibilities to switch to this one. Details can be found e.g. in an article on TechRepublic: Pro tip: How to unroot your Android device so you can update – and for the more "visual people", there's even an Youtube tutorial on this.

  • Thank you for your response , I tried root cloak with no luck – ZION Jun 10 '15 at 15:13
  • Answer updated for "worst case". – Izzy Jun 10 '15 at 15:19
  • I tried all the root hiding apps , no success – ZION Jun 10 '15 at 16:56
  • Sorry, in that case I'm out of ideas (except for the unrooting via SuperSU). – Izzy Jun 10 '15 at 18:13
  • Thank you for your response , I appreciated all the help – ZION Jun 10 '15 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.