4

I have 3 Android devices at home: Nexus 4 Android 5.1.1, Nexus 5 Android 5.1.1 and Lenovo Yoga 2 Android 4.4.2, all connected to my WiFi. The Nexus devices simply cannot receive Push Notifications (Gmail, Hangouts...GCM?) while the Yoga tablet can. On mobile data both Nexus devices can receive push notifications. If I connect them to my workplace WiFi everything is fine.

All devices have all the apps up to date. I've tried resetting the Nexus 5 to the factory defaults but it doesn't help. I've tried restarting the phones a couple of times but still no luck. The router is an ASUS AC68U, latest Merlin, on a 1Gbps internet connection. The only things that changed in my environment in the past 2 weeks are: 5.1.1 update and I moved to 1Gbps internet.

Is this related to the new Play Services Update? Or Android 5.1.1? Can I somehow look deeper into this? Logcat? Any help is appreciated.

  • 1
    Odd question: what sort of torrent traffic do you have going through that router, if any? I experienced this a couple of years ago, with no push notifications working, or taking a VERY long time to get through, on my Android devices, and Outlook regularly disconnecting. Eventually found that my router couldn't handle the workload of torrent traffic in addition to this. Any time my torrents were turned off, everything worked. Eventually replaced the router. Also check for firmware updates for your router. – TurboFool Jun 10 '15 at 22:39
  • Yeap, this is odd. When I tested it torrents were off. In the router connection log there are like a few tens of connections active. The router should be capable of handling several thousand connections. I don't even know where and what to look for. iPad works, Yoga 2 works, Nexus 4 and Nexus 5 don't... – lucassp Jun 11 '15 at 5:45
  • I have the router for about 9 months and it's working flawlessly. I only noticed the issue when my girlfriend told me she doesn't get her chat anymore a few weeks back...along with Android 5.1.1 – lucassp Jun 11 '15 at 5:51
  • Some people suggest I should disable IPv6 on my router. I'll try that when I get home – lucassp Jun 11 '15 at 6:39
5

It looks like GCM Push Notifications don't work with IPv6. I disabled IPv6 entirely in my router and now everything is fine. Though IPv6 was enabled for the past two years and I didn't have any kind of issue. Let's hope a Play Services update fixes it.

  • How to disable ipv6 in dlink router? – Ali_Waris Jan 2 '16 at 5:22
  • I'm on UVerse with a Motorola NVG589 router. Log in to your router at 192.168.1.254 and go to the Home Network tab and and click on Configure. There's an IP6 On/Off here. Turn it OFF and click Save, then go to the Diagnostics tab and click on Resets and click the RESTART button. One minute later I got flooded with notifications, and my WiFi icon is no longer orange now it's white. – Jim Bergman Apr 7 '16 at 20:48
1

Open port 5228 on your router. It's Googles like outbound wifi port. Worked for me.

1

The problem seems to be Android Lollipop, at least on 5.1 and later. I have 3 phones, a Moto X Google Play Edition (GPE), a Galaxy S2 and a Moto G 2nd Gen.

Moto X GPE and S2 run on Android 5.1.1 (the latter thanks to CyanogenMod) and suffer from the problem you describe. The Moto G on the other hand runs Android 5.0.1 and doesn't have that issue.

All the Push-Fixer apps on the Play Store don't do the trick for 5.1 devices that suffer from that. I'll try disabling IPv6 as suggested, but unfortunately the ISP-provided router doesn't let me turn off IPv6.

0

I was able to fix my issues at home by letting the router choose the channel automatically to avoid congestion. Almost immediately things began to ring and chime. I was previously getting the described scenario of dozens of notifications as soon as I left the proximity of my apartment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.