1

I'm new to this community so I hope there are no problems with my question. Also, sorry for my English.

So, until yesteday I've been using my Nexus 5 for debug porpuse, but this morning my PC didn't recognize the device when I plugged it to the USB port, though it was still charging.

Before that my phone was correctly recognized (it was listed with adb devices and also appeared in Eclipse)

I'm on Windows 8.1 (Android version 5.1.1 on device) and the most curious thing is that the Nexus doesn't even appear into Device Manager. Here is a list of things I've tried to solve the problem.

  • Restarting phone and PC several times
  • Uninstalled drivers from Device Manager and plugged the device right after, but nothing happened.
  • Tried several USB cables, on different USB ports
  • Tried MTP mode, PTP mode, with USB debugging both enabled and disabled
  • Tried to start Windows with Digital Signs disabled
  • Tried to connect the phone to a friend's PC and it got recognized
  • Tried to revoke USB debugging authorizations
  • Tried to adb kill-server; adb start-server

I really don't know what to do now, I'd really appreciate it if you'd help me, I need my PC to recognize my phone for my thesis work.

Thank you

0

You should go through the driver update process as outlined in Nexus Root Toolkit. I've gotten into this DLL-hell-type thing on my Windows 8.1 box before with multiple USB drivers for multiple devices. Following the NRT functions explicitly, fixed it for me.

NRT

  • Hey man, thanks a lot for your reply. I downloaded NRT and followed the instruction, but can't go through step 2 since it says to wait for MTP drivers to install and then to check if I can access my device internal storage, but nothing happens in both case. – Garet Jax Jun 11 '15 at 23:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.