0

As soon as I connect my Galaxy S2 with my computer it detects and Kies tell me that I have an updated version available. So I press update it downloads, prepare everything, then my phone goes to "Downloading do not turn off the target" and then Kies doesn't identify my phone. I've done it so many times before, every time I had an update from Samsung I've updated the same way.

I have tried different versions (1.5.49.0, 1.5.51.0, 1.5.53.0) of "Samsung USB driver for mobile phones" but nothing resolves the problem. I have tried to reset my phone to default but that didn't resolve the problem as well. As soon as it goes to "Downloading do not turn off the target" then the same thing happens. I don't know what to do, any help would be highly appreciated. BTW, my android version is 4.0.4 and baseband version I9100BVLPE if that helps.

  • Have you tried leaving the phone connected although kies doesn't recognize it? Because this happens with every device. – MANI Jun 14 '15 at 2:11
  • I kept it for an hour or so although Kies tell me to unplug the cable, take the battery off for 5 mins and re-plug in and re-try the update process. But I end up the same place every time. – Mahib Jun 14 '15 at 3:34
  • Try updating via WiFi. – MANI Jun 14 '15 at 4:45
  • I'm doing it over Wifi. – Mahib Jun 14 '15 at 8:14
  • 1
    Okay then. I'm not getting what's wrong with the device. I'll let you know if I find any information about this. – MANI Jun 14 '15 at 12:42
0

Try installing Kies and updating the OS on another computer. It is possible that you have the wrong drivers installed on the computer and as far as I know this cannot be undone.

  • Will try this. Thank you for mentioning that. – Mahib Jun 14 '15 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.