2

Okay, So i am running a Sony Xperia E1. It is not rooted or anything like that. Here is a load of information about it:

  • - Free space on Internal: 2GB (Enough to update GP Services, but if you read below it doesn't work.)
  • - Free space on SD: 31GB
  • - Phone, Text, Mobile data company: 3
  • - Model number: D2005
  • - Android version: 4.4.2 (Latest)
  • - Build number: 20.1.A.2.13
  • - Kernel Ver: 3.4.0-perf
  • - Google play version: 4.6.17
  • - Google play services version: 4.3.25 (1117561-038)

Why the problem happened:
I am one of the many people that get the insufficient storage error on my phone when trying to install an app from google play, but normally i just fix it by uninstalling google play updates (settings-apps-all-play store-uninstall updates (in app info)) and then clearing my cache, however about a month ago the uninstall button wasn't there any more: just the force stop and disable buttons. So i put up with it for a bit and didn't install anything, but now my google play servives needs really badly updating.
PROBLEM:
I installed a few non-important apps like Terraria with adb shell pm set-install-location 2 (linux) which basically sets the default installation to SD Card. it worked perfectly.
QUESTION:
IF i update Google Play services and force it on to the SD Card with the code above, will it mess up my phone? I have heard that installing stuff on to the SD removes some features. And if yes, PLEASE PLEASE can someone tell me how to uninstall updates for google play??? (Read above, the button in app info is gone)
P.S. I have tried so many methods of fixing the not enough storage, and my old method worked for me (See above) so I haven't not researched how to fix it.

Thanks very, very much in advance!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.