4

This question is essentially the same as Google Play: Error downloading app - insufficient space, but I want to fix it without rooting my phone. Clearing Cache, uninstalling Google Play updates and using cache cleaner apps do nothing. Any suggestions?

Background

My Sony Xperia T has over 10GB of free internal space and so does my SD card. Also, I have about 280MB of available RAM at any given point in the day. Despite this, every time I try to download another app of anything larger than about 24MB, the following error message appears,

ERROR, Error downloading. There is insufficient space on the device.

Although this message appears, I can go into Settings > Storage and see that I still have over 10GB of internal storage available on the device. The picture below shows my Internal storage. Please note the available space:

Internal Storage

One solution I have found is Something is secretly eating up my Acer Iconia A500 internal memory and I need help finding it, but unfortunately this specifically applies to someone who has 379MB remaining and can't find why there is not more. This is not the case with me because my phone clearly states I have 10GB of available internal storage.

I have already looked through insufficient-memory tag, which simply explains that I should either delete apps or move them onto my SD card. As you can see, neither of these suggestions apply to my problem because I already have over 10GB of available internal storage and over 10GB of available SD card storage space.

I have also looked through questions such as "Insufficient storage" when trying to install new app. The best answer given here is to clear data on Google Play. I have done this. It still doesn't help.

1

As far as I know, the only known "solution" for non-rooted devices whose cache and app data have already been wiped is to apply a factory reset.

If you change your mind and decide to root your phone, I suggest you install Android Platform SDK Tools on your computer, then root your phone, go to Android's Settings, select the Developer Options and then activate USB Debugging. Afterwards, use a USB cable to connect your Android device to the computer where you installed the Android Platform SDK Tools - henceforth referred as APST.

APST comes with ADB (Android debugger): open a shell window and use it to access the folder where APST was installed. Inside such folder there will be an executable binary file named adb (or adb.exe, if you're on Windows). Run the following command in the shell, in order to make ADB access the command prompt of your Android device:

adb shell

Now that you're in your Android device's shell (commands interpreter), run this command in order to become root (also known as superuser):

su -

Afterwards, run this command in order to check what's your system's default APK install location:

pm get-install-location

If the command above returns 2, then the Android package manager (pm) is incorrectly configured to install APKs in your device's external storage (e.g. microSD card) instead of in your device's internal storage (which is the correct place).

In order to fix it, run this command:

pm set-install-location 1

1 means internal storage media.

Now restart your device with this command:

reboot

After your Android system is restarted, run the Google Play Store app and try to install/update something. If it installs/updates, the issue's been fixed.

I found this solution by myself and it was the only one that worked for me. My device is a Motorola RAZR HD (XT925) running Android 4.4.2 (stock ROM). It had 2 GB of free space in its internal storage and 6 GB of free space in its external storage when the issue happened, but none of the other solutions worked: cleaning Google Play Store's cache and data, wiping the /cache partition, cleaning the Dalvik/ART cache, uninstalling the updates of Google Play Store and Google Play Services, running fstrim on the /data and /cache partitions, remounting /system as read-write and then running fstrim on it... Nothing.

A solution that seems to work in some devices (you can try it if my solution doesn't solve your problem) is to access /data/app-lib and then delete all duplicate folders except the ones with the largest number.

Example: let's suppose that in /data/app-lib you find the folders com.waze-1, com.waze-2 and com.waze-3. In such case, you shall delete folders com.waze-1 and com.waze-2 but do not delete com.waze-3.

After deleting all duplicate folders, restart your device and run Google Play Store app again. Did it fix the issue?

If you're still experiencing the issue, go back to the ADB shell, become root again (su -), then run cd /data/app-lib and finally run this command in order to recursively fix ownerships:

chwon system:system * 

Now restart your system (reboot) and cross your fingers. Sometimes another app messes with the ownership of these folders, hence making system their owner and group fixes the issue.

Good luck.

0

This worked for me on my Sony Xperia E3 and my Galaxy Note 10.1:
a) settings-apps-all-google play-uninstall updates (you will have to do this everytime you restart)
b) If this doesn't work: clear cache - with an app like 1tap cache cleaner or settings-storage-tap cache-clear cache. :)

protected by Community Jul 3 '16 at 13:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.