With reference to my question here: IM-A870L Radio Interface Layer broke down

Summary: My android phone broadband chip is dead. For some reason, its not working anymore. Now I can use the phone for other purposes but the problem is that the phone goes to look for broadband every now and then. Which not only drains battery but also hangs the phone. For e.g. if I press the power button to turn off the screen, I cannot put the screen back on immediately, it takes a couple of minutes before the phone gets back to normal.

My research resulted in this theory that every phone has two operating systems, one is your main operating system (i.e. Android, iOS, etc) and another parallel os is running with the broadband/gsm chip. Now the cells main OS tries to communicate with the gsm os to keep track of calls/sms. This communication is done through RIL (Radio Interface Layer), but if your gsm chip is dead, RILD is dead and thus the main os will not be able to connect to the RILD (RIL Daemon) through the socket associated for it.

Now the solution for this situation would be to tell your main os that it does not have to connect or keep on trying to connect to the RILD because it is not there anymore.

I am sure this can be done, because tablets that do not have any gsm also work with the same OS, which means in case of tablets, the OS is aware that there is no GSM to look for and thus there is no RILD connection attempts.

My question is that how can we tell our device that it does not have to attempt RILD calls? Is there a global setting or flag that tells the device that there is no GSM in this device??

My device is rooted and I can run any shell command or script.

Any help will be highly appreciated...

  • "I am sure this can be done, because tablets that do not have any gsm also work with the same OS" That's not quite true. Every different device uses a different build of Android. It's configured differently during compilation with the right drivers for all the hardware on that device. That's how the OS knows not to look for a GSM modem on a device that doesn't have one. It doesn't find out at runtime at all.
    – Dan Hulme
    Commented Jun 27, 2016 at 11:53

2 Answers 2


When you turn on your device, start adb shell and enter stop service rild. This would stop the RILD service and you can then use your phone for other purposes. However, on restart, the service would start again. For that, you need to edit your init.rc file. Just delete the lines that are starting the RILD service and then the RIL would not be a part of the OS anymore. Consequently, there will be no more attempts to the GSM modem.

Hope things are clear now.

  • Sorry for late reply, as the question was quite old and I did not get any response so I stopped checking back the page. The problem is that RILD is already not running on my phone, as I mentioned in my other thread that I get this message "RIL socket is not found" when I try to access the UMTS settings secret menu. Still I tried your given commands and they did not work. Thanks anyway! Commented Aug 26, 2015 at 7:20
  • BTW something weird happened past few days. As I had not lost hope and kept on trying different things, I flashed a Lollipop ROM but it crashed the phone. So I had to revert back and I then flashed the old ROM. After few days, it randomly started to behave like the very normal phone. GSM working and Baseband also showing up. Phone working just like normal, and send/receive calls and sms also worked! But then suddenly it gives a black screen with a message and an error logo saying that some application has crashed and caused system to reboot. Then the system reboots and baseband is gone again. Commented Aug 26, 2015 at 7:24
  • This above thing happened few times, that I get my phone like normal on restart but after few 10 mins, it crashes and shutsdown. But now since a couple of weeks, it is not happening again and the phone even reboots with the baseband unknown issue always there and the gsm not responsing. So I guess there could be something wrong with the ROM itself and maybe the hardware is still intact. There is nothing obvious in the electronic items :). Am still trying to figure out a way to fix my phone. Commented Aug 26, 2015 at 7:26
  • Great :) I think if the GSM worked fine for a few days, there might be no hardware problem. Let's see. Let me know if I can be of any help Commented Aug 31, 2015 at 10:29

Finally I got this solved!

The issue was with Android KitKat, it was having some sort of bad piece of code that was hanging my phone and draining all the battery.

I installed the Lollipop version offered by Resurrection Remix on this forum: http://forum.cyanogenmod.org/topic/103422-android-51-for-vega-iron-im-870slk-stable/

My phone is working fine now, no hanging, no battery drainage.

Although I still have the Baseband unknown and my GSM does not work, which implies that it could be hardware issue all along (there is still a chance that I can update my IMEI and it could work, but I can live with out it ;). But the phone works fine and does not hang eventhough radio layer is broken, which means this issue is handled smartly in the 5.1 while the 4.x is not liked for many more reasons by Android users.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .