3

I got a new OnePlus One recently and have noticed that the Google Maps Navigation Voice is in English (India) ( I bought the phone in India). This is very annoying and refuses to change no matter how much i change the TTS settings and delete the English(India) voice. It just redownloads and speaks in that voice. It is just fine English (US) on a Moto X I also bought in India (App not Updated).So my questions: a) Is this a "feature"? b) How do I fix it? I would like the English(US) Google TTS voice to work.

  • Have you found a solution yet? I have the same issue. – NVZ Oct 20 '16 at 17:12
  • @NVZ A few updates ago, it defaulted to the american accent, and now it's back to the indian accent, so I haven't found anything that works but I guess it's just forced on us. Honestly, the "Indian" pronunciations are just wrong and the voice is less fluent than the american one, so I don't see why Google insists on using it. – Dheeraj Y Dec 7 '16 at 17:12
  • Thanks for the reply. I hate the Indian accent to the core, but I guess Google thinks we Indians actually like hearing Indian accent more. Sad. – NVZ Dec 7 '16 at 17:20
0

You were probably nearly there and maybe missed one step. Unfortunately the easiest way to help you is to take you through the steps from the start. If you've already set something or downloaded the language, just move on to the next step, but check each step in order:

  1. Open "Settings" and under the heading "Speech" tap Language & input>Text-to-speech output. This takes you to a screen logically titled "Text-to-speech output".

On that screen, to set the engine, tap the cogwheel by Google Text-to-speech which takes you to the "Settings" screen (not such a useful name). Set:

  • "Language" to English(US) instead of "Use system language". If this isn't available, it will be after the next two steps.

  • "Setting for Google TTS Engine" as you want (update and WiFi only)

  • "Install voice data" then on the next screen (titled "Google TTS voice data") tap English(US) and ensure you have downloaded the voice(s) you want. If not, download them and wait until download is complete. If you have more than one English(US) voice downloaded (Male/Female), select the radio button by the one you prefer.

    1. Now back out one step to the screen titled "Settings". Check that Language is set to English(US) and not "Use system language". If you've downloaded and selected English(US) Male or Female in #1 above, this should now set it correctly.

    2. Now back out one step to the screen titled "Text-to-speech output". The last item on this screen is "Default language status". This should now show "English (United States) is fully supported". If it does, click "Listen to an example" and you should hear the language you set in the gender you chose.

If you followed these steps please come back and let us know it worked - or not ;)

  • Hi @brit0n I've tried all the steps you've mentioned. I think I see the inconsistency. When I go to install voice data under English(us) I see female but no delete or download icon to the right. Also Male is not available. Is this the problem because it still doesn't work. – Dheeraj Y Jun 26 '15 at 16:02
  • Doesn't work for me either. – NVZ Oct 20 '16 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.