5

This was probably an issue before but only became an issue when I changed providers in a foreign country. Running CM12.1 nightlies.

I can't connect to data and get the above message when I try to manually enter the APN settings.

I have tried:

  1. The other fix on this site to change permission in com.android.providers.telephony to 660 from 751 but that resulted in non-stop error messages from the phone app.
  2. Upgrade to the latest nightly with the new SIM inside. No change in service or in ability to change APN
  3. Delete the data and cache for the settings app
  4. Wipe cache and Dalvik cache.
  5. Downgrading to CM 11 milestone
  • 1
    More like that other question is a duplicate of mine, since mine came first, but both ours are about carriers in Brazil. I highly doubt that the solution for that question would've worked on mine, since I doubt I didn't at some point reboot and try to edit the APN settings while connected to WiFi. There are enough of these similar APN questions that there should be a wiki post with a list of solutions to try – raphael Sep 22 '15 at 16:51
3

edit: I should mention this fixed issues with Sprint for me, but perhaps googling in this vein could lead to finding a similar fix for other carriers.


tl;dr: I booted to recovery (TWRP), wiped, flashed CM12.1, 5.1 GApps, and the sprint.zip file from this XDA post and got LTE back.


I'm not positive my issue was the same, but the symptoms are very similar so I'm adding the solution I found. My LTE was working fine on CM12 and CM12.1 for perhaps 3+ months. My phone battery died overnight a couple days ago, and when I powered it on the next morning it didn't have LTE anymore.

Not only that, but I was getting the "APN settings not available for this user" under Settings -> Mobile Networks -> APN settings. After googling, and googling, and googling, I think I tried about every solution suggested for this issue:

  • setting /data/data/com.android.providers/telephony/database/telephony.db to higher permissions (e.g. 761)
  • deleting telephony.db and telephony.db-journal and letting the system re-create it (theoretically in the "proper" manner)
  • using *#*#4636#*#* and playing with the preferred network (LTE/GSM/CDMA, LTE only, etc.)
  • Turning on wifi, rebooting, waiting a while, and then turning it off and trying to connect to data
  • Adding a custom APN, which often wouldn't even save if I had the "APN settings not available for this user", and didn't seem to do anything otherwise.
  • I even went back to stock (upgrading radios and firmware in the process) by applying the latest RUU here. This updated my radios (I was on 3.31.651.2), and allowed me to update PRL/profile while I was at it. I didn't even have LTE from the stock ROM.

I ran into post where someone mentioned "the Sprint APN fix" so I googled for that and ran into this post, which points to this XDA post with the fix.

Downloading that file (sprint.zip) worked great for me, despite that post being ~2 years old. I just did the following:

  • boot into TWRP, wipe as usual as if installing a new ROM
  • flash CM12.1 (I used the most recent M8 snapshot from 09-01-2015)
  • flash 5.1 GApps
  • flash the sprint.zip file
  • wipe cache/dalvik

Rebooted and had LTE right away during setup. Soooo relieved, as this was killing me. I'm still puzzled as to how it could have gotten goofed from a previously working setup, but at least it's behaving now. Hope this helps others.

1

adapted from: http://xiaomi.eu/

my setup: SGS2 aka GT-I9100, CyanogenMod 12.1 Nightly, Android 5.1.1,

NO GUARANTIES, following worked for me

for rooted device with file manager

  • cd /data/data/com.android.providers.telephony
  • rm shared_prefs/preferred-apn*.x­ml
  • rm databases/telephony.db*
  • reboot
  • This worked for me, although I had to boot into TWRP and run these equivalent commands from its File Manager. This was on an HTC One running 12.1 20151007 Snapshot. – Cerin Dec 9 '16 at 20:49
  • I don't even have the databases folder... All I see is cache and code_cache... – sbrm1 Apr 18 '17 at 1:51
1

On a brand new yoga tablet 2 I spent 6h trying to get mobile internet to work. New users, reseting to factory defaults etc did not work. Did not want to hack/root the device just to try some of the suggestions. What solved my issue was accidentally tapping VPN in Wireless -> More. Where I have been asked to set PIN in order to get VPN to work. After setting the Swipe PIN I tried going to cellular data settings again as I had a bright thought that maybe is has somehow set the right permission on telephony.db file. The message was still there but the plus sign was active for the first time! I got my APN set up and cellular data works fine. HTH.

0

sigh factory reset did the trick.

  • Could you elaborate on the method? I just started having this problem, wiped everything listed in TWRP except for my external SD, re-flashed CM12.1 and gapps and still had the issue. Just used an RUU to return to stock, but even from stock I didn't have LTE. I feel like I've "factory resetted" sufficiently and the problem isn't going away. Just curious if you did something different... Thanks! – Hendy Sep 22 '15 at 0:45
  • Sorry, this is probably one of my worst answers. But indeed it seems you have gone above and beyond what I did. Have you tried re-flashing the radio or another radio? – raphael Sep 22 '15 at 10:48
  • I actually got it fixed and was just heading here to post the process (which I'll insert as a separate answer)! I wasn't totally up to date, so the RUU upgraded my radios. Ended up finding a "sprint APN fix" that did it... – Hendy Sep 22 '15 at 14:31
  • I'd still like to understand why this all happened... I hope to dig into the sprint.zip file and see what it did. My list of APNs is much shorter than the default CM12.1 list I used to have. Not sure if CM was getting confused or it was permissions, or some other file? – Hendy Sep 22 '15 at 14:48
0

For nexus 5: settings - more - mobile network - Access Point Names - + (edit access Point) - update name and APN - save.

-1

I experienced this problem. I found that the message "Access Point Name settings not available for this user" is misleading. It actually means "you haven't added any APNs yet", not "this user does not have the credentials to use this feature."

The solution (if you can call it that) was, at the APNs screen when the message appears, I found the button that allowed me to add a new APN.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.