1

I want to build an android image in my Nexus 5, but the adb devices cannot detect the device. I think I have a USB access problem in my laptop. When I plug the device, it is not connected. Here are some outputs of the various commands that were suggested when I googled it:

  1. lsusb -t:

    /:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
    /:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/9p, 480M
    
    /:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
    
  2. sudo fdisk -l

    Attention : identifiant de table de partitions GPT (GUID) détecté sur « /dev/sda » ! L'utilitaire fdisk ne prend pas GPT en charge. Utilisez GNU Parted.
    
    Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
    255 têtes, 63 secteurs/piste, 121601 cylindres, total 1953525168 secteurs
    Unités = secteurs de 1 * 512 = 512 octets
    Taille de secteur (logique / physique) : 512 octets / 4096 octets
    taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
    Identifiant de disque : 0x8c377765
    
    Périphérique Amorçage  Début         Fin      Blocs    Id.        Système
    /dev/sda1               1  1953525167   976762583+  ee  GPT
    La partition 1 ne commence pas sur une frontière de cylindre physique.
    
  3. dmesg | tail ⇒ plug the usb ⇒ dmesg | tail -n 20: here is the difference between the 2 previous commands:

    [ 2919.365968] [UFW BLOCK] IN=wlan0 OUT= MAC=01:00:5e:00:00:01:c4:2c:03:2f:2d:54:08:00 SRC=141.223.83.156 DST=224.0.0.1 LEN=44 TOS=0x00 PREC=0x00 TTL=1 ID=63097 PROTO=UDP SPT=64283 DPT=8612 LEN=24 
    [ 2939.662014] [UFW BLOCK] IN=wlan0 OUT= MAC=01:00:5e:00:00:01:c4:2c:03:2f:2d:54:08:00 SRC=141.223.83.156 DST=224.0.0.1 LEN=44 TOS=0x00 PREC=0x00 TTL=1 ID=9057 PROTO=UDP SPT=54364 DPT=8612 LEN=24 
    [ 2954.005896] [UFW BLOCK] IN=wlan0 OUT= MAC=01:00:5e:00:00:01:c4:2c:03:2f:2d:54:08:00 SRC=141.223.83.156 DST=224.0.0.1 LEN=44 TOS=0x00 PREC=0x00 TTL=1 ID=65052 PROTO=UDP SPT=61778 DPT=8612 LEN=24 
    [ 2975.324471] [UFW BLOCK] IN=wlan0 OUT= MAC=01:00:5e:00:00:01:c4:2c:03:2f:2d:54:08:00 SRC=141.223.83.156 DST=224.0.0.1 LEN=44 TOS=0x00 PREC=0x00 TTL=1 ID=21456 PROTO=UDP SPT=59758 DPT=8612 LEN=24 
    [ 2996.844609] [UFW BLOCK] IN=wlan0 OUT= MAC=01:00:5e:00:00:01:c4:2c:03:2f:2d:54:08:00 SRC=141.223.83.156 DST=224.0.0.1 LEN=44 TOS=0x00 PREC=0x00 TTL=1 ID=58470 PROTO=UDP SPT=55238 DPT=8612 LEN=24 
    

4.usb-devices

    T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 2
    D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=1d6b ProdID=0002 Rev=03.13
    S:  Manufacturer=Linux 3.13.0-55-generic ehci_hcd
    S:  Product=EHCI Host Controller
    S:  SerialNumber=0000:00:1d.0
    C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
    I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

    T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480 MxCh= 8
    D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
    P:  Vendor=8087 ProdID=8000 Rev=00.04
    C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
    I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

    T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 9
    D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
    P:  Vendor=1d6b ProdID=0002 Rev=03.13
    S:  Manufacturer=Linux 3.13.0-55-generic xhci_hcd
    S:  Product=xHCI Host Controller
    S:  SerialNumber=0000:00:14.0
    C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
    I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

    T:  Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=5000 MxCh= 4
    D:  Ver= 3.00 Cls=09(hub  ) Sub=00 Prot=03 MxPS= 9 #Cfgs=  1
    P:  Vendor=1d6b ProdID=0003 Rev=03.13
    S:  Manufacturer=Linux 3.13.0-55-generic xhci_hcd
    S:  Product=xHCI Host Controller
    S:  SerialNumber=0000:00:14.0
    C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
    I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

Thank your for your help :)

1 Answer 1

-1

Do you have adb installed? Added the android rules and etc? I was in the same boat last night kind of, was trying to run a logcat. Google adb for whateverdistro you are using. Once I set up adb/android rules, my phone would show up via lsusb

Also, not sure if it matters, but do you have USB debugging turned on?

I assume since you are trying to build an image, that you know the basics, but have you tried searching/posting on xda as well?

1
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – Andrew T.
    Commented Jul 30, 2022 at 16:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .