My Asus TF700T with Cyanogenmod 11 M12 (20141112) and ClockworkMod Recovery v6.0.4, remains stuck in a boot loop after every reboot attempt. Earlier Cyanogenmod versions (I believe, it was 10.2 and 11 M7) had the same result.

Trying to install the Android firmware (WW_epad-user-10.6.1.14.10.zip) fails with

assert failed: package_extract_file("blob", "/tmp/blob")

and it seems the reason for this oddly unspecific error message is that it is unable to mount /data. I do not know why, but it seems this hints at a larger problem. "Wiping data / factory reset" fails with

Error mounting /data!

and

Error:unknown volume or path [/sd-ext]

Updating to some other Cyanogenmod succeeds, but it still fails to boot.

I would like to get the device to reliably boot some system (I don't care which) with which it would be usable again.

Some threads (on Transformer Forum) seem to suggest that in this case the system is pretty much broken and that only nvflash and/or wiping everything from fastboot might help. Following this thread for instance was suggested. It contains a "quick guide" which I do not understand (what does "run download.bat" mean if you run GNU/Linux, not Windows?), other websites (this and this) list some very complicated commands which require additional files (config, blob.bin, bricksafe.img) for which I do not understand where to get them from. It seems to be suggested that they have to be extracted from the existing Android installation - which might be difficult if its filesystems cannot be mounted (see above).

I am sure, I misunderstand something here but, having no experience with Android, I do not know what.

Currently, I just want to restore some system (Cyanogenmod, Android, or anything else) with which the device would be usable again so that I can sell it or give it away to someone who would not necessarily have deeper computer knowledge (and would therefore probably not have any more luck in repairing a broken Android/CM than I had). I appreciate any help in accomplishing this.

EDIT (further information): The Android firmware (WW_epad-user-10.6.1.14.10.zip)contains the following:

$ unzip -l WW_epad-user-10.6.1.14.10.zip 
Archive:  WW_epad-user-10.6.1.14.10.zip
signed by SignApk
  Length      Date    Time    Name
---------  ---------- -----   ----
        5  2011-03-22 11:21   META-INF/com/google/android/resource
       24  2011-03-22 11:21   META-INF/com/google/android/rule
   893496  2011-03-22 11:21   META-INF/com/google/android/update-binary
      111  2011-03-22 11:21   META-INF/com/google/android/updater-script
820149641  2011-03-22 11:21   blob
     1619  2011-03-22 11:21   META-INF/com/android/otacert
      561  2011-03-22 11:21   META-INF/MANIFEST.MF
      614  2011-03-22 11:21   META-INF/CERT.SF
     1658  2011-03-22 11:21   META-INF/CERT.RSA
---------                     -------
821047729                     9 files

EDIT 2 (Jul 8; further information about inability to enter fastboot mode):

Following the suggestion by gruhlke I found that adb devices finds the device only if clockwork mode (recovery kernel) is booted (not while in the bootloader, not in cyanogen's boot loop):

# adb devices
List of devices attached 
0166160e04480c05    
#

Then (and only then) I can also do adb reboot bootloader (which I can also do manually by pressing VolUp while booting). Form there I select USB Fastboot mode; the device says

Starting fastboot USB download protocol

and that is the end of it. The device never comes online; doing

fastboot devices

from the computer never lists any devices.

EDIT 3 (Jul 12, more info on fastboot from windows):

trying fastboot from windows (with this tool) results in just as little success; "fastboot devices" never recognizes the device. However, there is one difference to fastboot from Linux: the message "Starting fastboot USB download protocol" is only shown with the cable unplugged; from this, I conclude that the device is trying and failing to build a connection with the windows-fastboot in yet another infinite loop.

EDIT 4 (Aug 4, repaired filesystem, problem persists):

I repaired the filesystem by reformatting /dev/block/mmcblk0p8 after discovering (inside the shell on the device, where I got using "adb shell" from the connected computer while the device was in recovery mode (Clockworkmod)) from /tmp/recovery.log that mounting /sdcard/ tried and failed to mount this block device (among several others which all did not exist). the filesystem is fixed doing

mke2fs /dev/block/mmcblk0p8

After the next normal bootup, cyanogenmod got to the point where the user should select the language, wifi etc - but it then rebooted automatically without the selection completed and is back in the boot loop. The device also can still not be put into fastboot mode. A new zip can now be put on the device using "adb push", but it can not be installed (installation fails with "(Status 0) Installation aborted.", no more detailed error description is given. Not even in the /tmp/recovery.log)

Obvious questions would be:

  • Is there a way to force installation of a zip (if the "(Status 0) Installation aborted." thing is just a quirk of clockworkmod) inside "adb shell"? (The "recovery --update_package=/path/to/.zip" command does not go successful either. There are error messages, but as the device reboots, they are shown too briefly to be red.)
  • Is there a way to force putting the device into fastboot mode from "adb shell"? (Some forums suggest something like "idme bootmode 4002" but this does not work as the idme command does not exist, I guess this existed in a past version of android(?) or in a different recovery mod (?) or only for different devices (?).)

EDIT 5 (Aug 4, still more information: /data partition inconsistent after every cyanogenmod boot attempt):

I found that in spite of reformatting the filesystem it turns out to be inconsistent again after every cyanogenmod boot attempt. I can only adb push and install zips immediately after reformatting (done that several times now), not any more after the next boot attempt. Trying to install android, not cyanogenmod (the WWW_epad-user-10.6.1.14.10.zip) results in a reboot to recovery during the installation process, it is evidently not successful and cyanogenmod is still installed afterwards.

Both parted and fdisk (in "adb shell") do not recognize the partition table. Perhaps, Firelord is right with the last (most recent) comment, that this should be treated as hard bricked and rebuilt starting with the partition table. (How many times have I wished that this was an Intel architecture that could be booted from a livesystem - none of this would be a problem!)

EDIT 6 (Aug 4, fastboot working after all, but boot loop continues)

It seems, for tf700t, fastboot does not respond to "fastboot devices" and all other commands require option "-i 0x0B05". With this, fastboot would presumably have been working all the time. I can now flash recovery (flashed twrp mod just to verify that).

So far so good. But the boot loop continues, /dev/block/mmcblk0p8 still goea inconsistent after every boot attempt with cm, android / WW_epad-user-10.6.1.14.10.zip can still not be installed. Fails with "Error executing updater binary in zip".

On the matter of flashtools for low level flashing as suggested by Firelord: I could not find any for this particular device. Actually, this xda-developers thread suggests using bricked tf700t as paperweights, others are along the same lines.

But hey, fastboot works - it must be possible to accomplish something from there.

Questions at this point would be:

  • How do I find an explanation of what's causing the boot loop and/or the damage to the partition that coincides with it?
  • Is it possible to flash some ROM that is not cm, if only to see if the boot loop is also present there?
  • If the reason for the boot loop etc is damage to the partition table: is it possible to repair the partition table from fastboot (or do anything helpful from there for that matter)? (However, the gentoo wiki says that on tf700t the partition table is proprietary which would explain why fdisk and parted can not work with it.)

EDIT 7 (Aug 5, spontaneous reboot from recovery to recovery with files vanishing (under twrp recovery mod))

in twrp mod it will from time to time reboot to recovery when I try to adb push things to the /sdcard/ share on the device. After this, the things previously adb-pushed there do not show up any more. I am quite certain that something is wrong with either the partitioning or the disk. Unfortunately, I do not know how to find out, which and/or what to do about it.

  • 1) Have you looked at the commands listed under download.bat? You can post the file here if you have it. 2) The blog.bin, bricksafe.img and others probably can be found in fastboot type stock ROM for your device. – Firelord Jun 23 '15 at 6:10
  • Thanks, Firelord. 1) I am not sure where I can find the download.bat. Should it be part of the firmware?, on the device?, part of nvflash? 2) I am not sure what stock ROM means in this context. If it refers to the Android firmware, the files are apparently not there (I added the list of the files in the archive as further information to the question). – 0range Jun 24 '15 at 9:17
  • Have you tried Option 1a here? – Firelord Aug 4 '15 at 16:21
  • Thanks, Firelord. I did now. As far as I can see, no change (boot loop persists and I still can't get into fastboot mode). – 0range Aug 4 '15 at 16:35
  • The question is very long, and some people like to avoid very long text. Now that fastboot commands are working, I suggest you to remove the text which is now obsolete so that question's length can be decreased. – Firelord Aug 5 '15 at 3:29

Following instructions worked for me:

  1. I installed fastboot from here.

  2. Then I booted the TF700T into fastboot mode, connected it to my Linux machine, and entered the command:

    fastboot erase userdata
    
  3. When the above command was finished I continued with booting into recovery. From there I followed the CyanogenmodWiki, and entered the command:

    adb push cm-11-20150614-NIGHTLY-tf700t.zip /sdcard/
    
  4. After this, it was possible to mount SD card in the Recovery Menu, and then I chose "Install zip from SD card".

  • Thanks for your answer. Unfortunately, I cannot enter fastboot mode (updated the question accordingly). I do not know why since there is no error message. – 0range Jul 8 '15 at 19:22

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.