2

I have noticed I have Preferred Activity Setter after the most recent update of Google Play Services, and it has been wreaking havoc on my Samsung Galaxy prevail LTE on my stock browser called "Internet" or "Browser" on older phones where it takes me to a site where there was moleculas content and Chrome loads the page then when finished it loaded page disappears except for the URL bar.

I have AVG Antivirus and it also says Preferred Activity Setter is considered a potentially unwanted program (PUP is now invalid, now considered malware). I have tried to force stop it, and it is still active while the "force stop" is greyed out.

Anyway to remove this without rooting it and doing it that way?

  • 1
    Seems a Sprint app: "Sprint app but not sure of purpose - Removed and have seen no issues" – Andrew T. Dec 22 '15 at 9:35
  • 1
    Yeah, as Andrew said, it's some system app.. Not a virus.. It's a false-positive report by your anti-virus. If you want to remove this app, you definitely have to root your phone. See this discussion: What is the Preferred Activity Setter – Gokul NC Dec 22 '15 at 11:54
  • You may not be able to remove it, but you can probably durable it under Settings > Apps (Make site you have enabled "Show System Apps") – Tamoghna Chowdhury Feb 25 '16 at 12:36
  • @Cowdhury I have tried Force Stop ignoring the warning as now is passively working (don't know how to explain it any better as the app is still running with force stop greayed out) tried clearing all data, using other applications to keep the perferd activity setter disabled now the only solution is root and remove – Cord Parker Feb 25 '16 at 17:57
0

No. System apps cannot be removed without root privileges. Ignore this warning from AVG. I myself removed it using Titanium Backup, but once again you need to have root for that. If you are ready to take that step, knowing that it will void your warranty, then head over to XDA and research the rooting methods available for your particular phone model.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.