2

My phone is connected to the wi-fi but my Whatsapp messages won't send. They have a clock icon next to them.

  • Have you tried using another wi-fi connection? If the one you're on now is routing whatsapp traffic badly, then it may cause that. – Jim Jun 26 '15 at 13:28
5

First wait for sometime, while device is connected to wifi and it starts to auto update apps and uploading/syncing of local data backup such as photos, notes, contacts get started.

If you're seeing a syncing sign on the top of the screen as shown in picture then wait for sometime until process ends.

IMG:

Alternatively, the other major thing could be settings turned on that is "stop app using data in background".

I use above settings to prevent specific apps from using heavy data in background.

Read the linked article.

  • Yes, I could have but someone else would have probably down voted and moved on. Next, please use quotes only for direct quotations from a source to add to your answer. Not for your answer text. Thanks for cleaning up +1 – beeshyams Dec 4 '18 at 13:55
  • Images are also subjected to our referencing policy. That image appears to have come from this source. – Firelord Dec 4 '18 at 18:37
1

Here is a solution that should fix it

  1. Phone Settings
  2. Apps
  3. WhatsApp
  4. Data Usage
  5. Wi-Fi Disabled - Toggle this back to ON.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.