3

I have an ASUS ZenFone 2. I have tried using ASUS USB drivers and Google Android composite ADB drivers on my computer, but neither recognize the device while it is in recovery mode.

Can anyone help me solve this problem?

11
  • 1
    Reading between the lines, you're using Windows on your computer. Have you checked if the device is even found at all – i.e. does it show up in the device manager, and with what additional information?
    – Izzy
    Commented Jun 27, 2015 at 13:12
  • yes it shows my device in device manager when my phone is on and plugged via usb (2.0/3.0 tried both) and also there in no exclamation mark which means my drivers are correctly installed. But when i boot into recovery mode the device manager don't show my device.
    – Anuvicleo
    Commented Jun 27, 2015 at 14:01
  • 3
    Which recovery are you using? The stock recovery probably doesn't support ADB.
    – user43185
    Commented Jun 27, 2015 at 14:54
  • I'm using stock recovery. Are you sure stock recovery does not support adb because as far as i know stock recovery does support adb. If google made adb for android then its suppose to work on stock recovery, why need custom recovery.
    – Anuvicleo
    Commented Jun 27, 2015 at 16:34
  • Maybe your stock recovery is too old. Try updating it if you can (although it's unlikely that it's possible) or install a custom recovery.
    – Arielle
    Commented Jun 27, 2015 at 16:42

3 Answers 3

4

Had the same problem, plus the device was shown with a yellow exclamation mark in the device manager but only when in recovery mode.

Solution was to install the Google USB drivers for this device again:

  • Google and Download "Google USB Driver"
  • Open device manager
  • Right click device
  • Update Driver Software
  • Select "Browse my Computer ..."
  • Select "Let me pick ..."
  • Select "Android Device"
  • Select "Android ADB interface" ...
2
  • Joined specifically to say thank you! I'd been fighting with this problem for an hour.
    – Easy Tiger
    Commented Jan 10, 2019 at 21:00
  • With a Samsung Galaxy A6 in recovery mode connected to the PC, in Device Manager I found "Android Phone" (instead of Android Device) and instead of "Android ADB interface" I selected "Samsung Android ADB Interface". After that, the command `adb devices" worked!
    – q-l-p
    Commented Dec 31, 2019 at 17:07
2

I had the same issue and was able to solve it by updating Intel USB Driver for Android Devices. It is available here: Official

0
1

do you have android debug bridge enabled in developer options? i'm pretty sure that will enable it in recovery mode, too.

with your device booted, go into settings and choose "About phone (or tablet)." scroll down and tap on "Build number" 7 times.

now go back out to the main settings screen and you should see "Developer options." Select that and make sure the selection to "Enable USB debugging" is checked.

7
  • did you mean usb debugging mode? That's turned on, or something else should be checked too?
    – Anuvicleo
    Commented Jun 28, 2015 at 10:12
  • yea, i'll edit that. Commented Jun 28, 2015 at 10:13
  • 2
    adb devices actually works while my device is on, but in recovery mode it doesn't.
    – Anuvicleo
    Commented Jun 28, 2015 at 10:18
  • 2
    with the device booted and connected via USB to your PC, enter adb shell getprop into the command prompt. look for ro.adb.secure and ro.debuggable. ro.adb.secure will = 0 and ro.debuggable will = 1 if the device allows ADB access in recovery mode. Commented Jun 28, 2015 at 10:40
  • also, it looks like the device needs to be in active sideload for ADB to see the device in recovery mode. here's a link that might help explain the process. Commented Jun 28, 2015 at 10:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .