I have an application that refuses to start on a rooted phone.

I don't want to unroot my phone just for that application; is there any way to run an application inside an unrooted sandbox from a rooted phone (Nexus 5, Stock Android 5.1, rooted)?

  • Did you try adb logcat to see what's going on? If you have the access to the source of the app, then you may give it a try to see whether it's checking su's or a custom kernel's presence, or not.
    – Firelord
    Commented Jun 28, 2015 at 17:20

2 Answers 2


You can temporarily disable root access (and then enable it anytime later you want). To do this, there are two most common and simple methods->

1) Turn off root access using the permission manager: Since you are rooted, you must also be using some permission manager like supersu or superuser etc. You can go into its respective settings and disable root access.

2) Turn off root access from Developer Options: Go to Settings->Developer Options and in the option Root Access select None. This will also disable root access for apps.

Besides these, if it still doesn't work, you can either try completely uninstalling permission manager (this wont unroot you, you can root again anytime by installing them again); or you can simply go to system/bin and system/xbin and delete/move somewhere else a file named su (its the main binary file responsible for root permissions. I suggest you atleast get a backup of it). Further, use these methods only if none of the above two work.

  • Thanks for your prompt response. The application actually doesn't even trigger SuperSU, so I tried disabling entirely the Developer Options (as I didn't find a "Root Access" option) and it still refuses to start. I get a popup at startup telling me that it doesn't work "because my operating system has received alterations or has been rooted". Indeed, I have a custom kernel (for battery saving) and I am rooted (but developer options off). Perhaps the custom kernel is the blocking part then?
    – Thomas
    Commented Jun 28, 2015 at 9:25
  • Can you please provide me with app's name? Perhaps I can test it out and some experimentation with it? It will enable us to get on root cause of this more easily. Commented Jun 28, 2015 at 9:27
  • This is not on the market (not on F-Droid either) and I am not allowed to share that application but I'll try flashing back the original kernel.
    – Thomas
    Commented Jun 28, 2015 at 9:30
  • Woaw, I flashed stock kernel, stock recovery, disabled Developer Options, disabled SuperSU (SuperSU Settings > Unchecked Enable) and... still it refuses to run! I guess the application has strong protections... I quit trying to run it as it's not worth it and accept your answer as I believe "in general" your solution works. Thanks, Thomas
    – Thomas
    Commented Jun 29, 2015 at 14:55
  • Well then I guess it checks it in a similar way that whatsapp does. If you noticed whatsapp will always detect that you have a custom/modified system/rom, even without granting it root permissions. So I am guessing thats where you should begin your research (probably contacting developers if you can?). Again, almost every app has alternatives and its all upto you to proceed further or not ;) However, there is no way to run an app as in perfect "sandbox". I think its not related to rooting, rather custom elements in system Commented Jun 29, 2015 at 15:29

Just don't granr super user permission when prompted. If you get no SU prompt, then the app is doing nothing requiring root permissions

  • "refuses to start on a rooted phone" - you're talking about a different problem here.
    – Andy Yan
    Commented Mar 10, 2017 at 10:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .