I am currently using a ROOTED "Huawei MediaPad 7 Lite" tablet and am having issues entering the bootloader. When powered on and connected to a PC, the device is seen in adb using the command adb devices (driver is working). However, when I try to enter the bootloader, adb reboot bootloader, the device malfunctions in windows:

USB device not recognised

The same occurs when the tablet is powered off, and the power and volume up keys are held down (entering bootloader manually). In 'Device Manager', there are NO 'Unknown Devices' missing drivers. Instead, there is an issue with the USB controller:

Unknown USB Device

Due to this malfunction, I cannot install a driver for the tablet when in bootloader mode. To clarify, the tablet works OK when powered on and connected to a PC, but malfunctions when in bootloader mode. I have tried this on 3 different computers with 4 different MicroUSB cables with no success.

I also have a second identical MediaPad 7 Lite, and in trying the above steps also has the same problems. It seems Huawei have done this as a preventative measure (meaning it is a device specific issue), but does anyone know how to make the PC recognise this device properly when in bootloader?

EDIT: The bootloader screen is unusual. Without the cable connected, when the bootloader is entered (by pressing power with volume up & down), the following options exist:

  • continuing to hold volume up brings up a screen which is used to update the tablet software from a file on the external MicroSD card
  • continuing to hold volume down initiates an automatic recovery process
  • releasing all buttons reboots the tablet automatically after a few seconds

With all of the above options, I tried plugging the tablet into my PC. However, Windows does not recognize the tablet at all (nothing pops up).

  • Try manually booting into the bootloader on the device and then plugging it in to the PC. How you manually boot into the bootloader will vary between devices and as I don't own a Huawei MediaPad 7 I don't know how you do it on this device. Generally, try turning off the device and then holding the power and volume down buttons down.
    – LJD200
    Commented Jun 30, 2015 at 15:52
  • I also tried this as well @ljd200. As soon as the device vibrates and the screen turns on, I plug the cable into my PC. However, it is not detected at all by Windows (no device connect sound or nothing in device manager). The bootloader screen appears and the device then reboots.
    – Joshua
    Commented Jul 1, 2015 at 11:56
  • Hmmm... I would try a different PC if you have access to one.
    – LJD200
    Commented Jul 1, 2015 at 14:58
  • Like I said in the OP, I have tried this on 3 separate computers. It is a device problem...
    – Joshua
    Commented Jul 1, 2015 at 15:00
  • Oops! Sorry, I didn't see that. A final suggestion would be to try a different OS such as a Linux distro to see if it is a Windows thing or not. If that doesn't work, I'm afraid I don't know what will. Sorry I couldn't help more.
    – LJD200
    Commented Jul 1, 2015 at 15:03

1 Answer 1


As the device has failed to be recognised correctly (failed) I would suggest uninstalling the device from windows or updating the driver, however looking up device id in this forum,suggests various other options could fix the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .