My Galaxy S3 (running CM11) isn't showing at all under My Computer. The phone is set to MTP.

Under my computer the GT-i9300 shows up under 'Unspecified'. When I go into the device properties it shows up as Google Galaxy Nexus ADB Interface even though I have debugging mode turned off.

When I try to update the device manually to MTP USB Device or Samsung Mobile MTP Device I get an error saying "This device cannot start. (Code 10)"

I've tried un-installing and re-installing the drivers, as well as the registry tweaks mentioned in this XDA thread but I do not have the UpperFilter key present. I've also tried installing Kies and running the connection troubleshooter with no luck. Any suggestions please?

Many thanks

It appears that you are using Android Studio (or another IDE). Try turning on developer mode and then connect the device.

  • Thanks, when I run under developer mode it still won't work unfortuantely :( – Nick Jul 8 '15 at 12:32
  • @Nick Did you enable USB Debugging? What about verify apps over USB? What happened to me was, I had to wait for an RSA certificate to pop up on my phone to verify that it is connected properly.... – Avi Parshan Jul 8 '15 at 14:27

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.