1

On an Android Lollipop powered Sony Xperia M4 Aqua, no notifications are being shown for new SMS arrivals in the notification bar nor the ringtone that was set is being played.

5
  • As the phone is not mine and I do not have it in my hands it will take some time to test each suggested answer. Jul 8 '15 at 12:52
  • Have you tried restarting the phone and the problem persists?
    – Lucky
    Jul 8 '15 at 12:58
  • Is the SMS stock app set as the default SMS app you can change that on your phones settings Jul 8 '15 at 13:00
  • @Lucky Tried restarting yes Jul 8 '15 at 13:07
  • I don't know about SMS but had an issue when manually selected ringtone wasn't playing but defaulted to system ones. Turned out to be a known issue and this answer (deleting data of com.android.providers.media under Settings -> Apps) helped.
    – Firelord
    Jul 8 '15 at 13:15
2

Note: Applicable for any Android app which doesn't work in the way it should...

Probably Show notifications (in app manager) for Messaging app might have been disabled. To enable it again just navigate to Settings>Apps>All apps>Messaging and enable Show notifications. If the problem still persists try ---

  1. Clear data and Clear cache on the same page.
  2. Disable & enable the app or Force stop & restart the mobile.

These are the basic steps to troubleshoot the apps which misbehave in any Android phone. If the problem still persists try trusted third-party apps like Textra SMS, GoPro SMS etc. as a temporary solution.

P.S: Factory formatting the phone solves all the problems but resetting is recommended only when it is extremely necessary.

1

I had this same issue and realized my Sony Z3 was in Stamina mode. My battery level was at 25% which activated Stamina mode to save battery life by turning off certain functions including the notification light. Once I charged my phone the notification light started to work again. Also if you want your notification light to work at all times, just turn off Stamina mode.

1
  • Although this was not the issue, Stamina Mode sucks. I only use Ultra Stamina mode to go full stupid phone if I want to conserve battery May 9 '16 at 13:44
0

This happens when you select any of the priority modes and forget to turn them off. Try doing this:

Settings- Sound and Notifs- App notifs- Messenger- settings icon- Toggle Notifications.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.