I'm working with an InForce 6540 board that has 5.0.2 Lollipop installed.

I am trying to connect a display device that has a max resolution of 720p at 60hz. I am using a micro HDMI connection.

The 6540 detects the display as a 1080p dislplay and uses that resolution.

I tried to change the resolution with adb root.

adb shell cat /sys/devices/virtual/graphics/fb1/edid_modes 
( to check which modes the display device supports)

adb shell setprop hw.hdmi.resolution 13 
(or other supported number, checked the .cpp file to see what each number means for resolution.)

adb shell stop

adb shell start

This did not work, and I tried it on a different display device that supports more resolutions, and it did not work either.

I have also tried the command wm, but that only resizes the amount of screen it is currently using. (It scales versus changing actual display resolution)

My display shows static on the bottom half, and on the top, it shows the whole display but cut. The right side of the display is cut and displayed on the left with everything shifted to the right.

Any help would be appreciated. I know this is not a normal problem.

  • The resolutions along with the edid modes are also listed in dmesg ( or logcat). Filter on EDID to get lines such as: "hdmi_edid_add_sink_video_format: EDID: format: 16 [1920x1080 p60 16/9], Supported" - your solution worked on my Note3 Lollipop.. thanks!
    – JJones
    Feb 5, 2016 at 8:18
  • Community bump prevention: this question was closed because the question seems to have been abandoned (OP hasn't visited the site after posting the question, and no answers have score above 0). If anyone can evaluate the existing answers, feel free to vote accordingly and reopen the question (or mod-flag the question requesting for reopening). For anyone else having the same issue, please post a new question and refer to this question as additional context.
    – Andrew T.
    Oct 13, 2023 at 18:23

2 Answers 2


I'm running an older version, 4.1.1, on a cheap tablet. On this unit, it's Settings-->HDMI-->HDMI Resolution.



I ran into the same issue on the 6640, the problem I had is that in order for the change to take effect you must unplug the HDMI and plug it back in.

After you call setprop hw.hdmi.resolution try physically unplugging the HDMI display and plugging it back in.

Not the answer you're looking for? Browse other questions tagged .