2

I have rooted lenovo p780 with VIBEUI 2.0 (not sure that this matters). The issue is well described in subject. When I enter /storage/sdcard0 directory via remote terminal it appears empty. It's all the same for samba - I can see nothing. But in Total Commander I can see that there are actually a lot of files. What could be the reason? I thought it is not mounted but could it be unmounted only for certain apps?

130|root@P780:/storage/sdcard0 # ll /storage
drwxr-xr-x    2 root     root             0 Jul  7 10:02 sdcard0
drwxr-xr-x    2 root     root             0 Jul  7 10:02 sdcard1
drwxr-xr-x    2 root     root             0 Jul  7 10:02 usbotg
drwxr-xr-x    2 root     root             0 Jul  7 10:02 usbotg1

,

root@P780:/storage/sdcard0 # ll -a /storage/sdcard0                                                                                                                                                                                  
drwxr-xr-x    2 root     root             0 Jul  7 10:02 .
drwxr-x--x    6 root     1028             0 Jul  7 10:02 ..

,

root@P780:/storage/sdcard0 # ll /sdcard                                                                                                                                                                                              
lrwxrwxrwx    1 root     root            16 Jul  7 10:02 /sdcard -> /storage/sdcard0

,

root@P780:/storage/sdcard0 # mount
rootfs / rootfs ro,seclabel,relatime 0 0
tmpfs /dev tmpfs rw,seclabel,nosuid,relatime,mode=755 0 0
devpts /dev/pts devpts rw,seclabel,relatime,mode=600 0 0
none /dev/cpuctl cgroup rw,relatime,cpu 0 0
proc /proc proc rw,relatime 0 0
sysfs /sys sysfs rw,seclabel,relatime 0 0
selinuxfs /sys/fs/selinux selinuxfs rw,relatime 0 0
none /sys/fs/cgroup tmpfs rw,seclabel,relatime,mode=750,gid=1000 0 0
none /acct cgroup rw,relatime,cpuacct 0 0
tmpfs /mnt/secure tmpfs rw,seclabel,relatime,mode=700 0 0
tmpfs /mnt/asec tmpfs rw,seclabel,relatime,mode=755,gid=1000 0 0
tmpfs /mnt/obb tmpfs rw,seclabel,relatime,mode=755,gid=1000 0 0
/emmc@android /system ext4 ro,seclabel,relatime,noauto_da_alloc,commit=1,data=ordered 0 0
/emmc@usrdata /data ext4 rw,seclabel,nosuid,nodev,noatime,discard,noauto_da_alloc,data=ordered 0 0
/emmc@cache /cache ext4 rw,seclabel,nosuid,nodev,noatime,discard,noauto_da_alloc,data=ordered 0 0
/emmc@protect_f /protect_f ext4 rw,seclabel,nosuid,nodev,noatime,nodelalloc,noauto_da_alloc,commit=1,data=ordered 0 0
/emmc@protect_s /protect_s ext4 rw,seclabel,nosuid,nodev,noatime,nodelalloc,noauto_da_alloc,commit=1,data=ordered 0 0
2

Just three words: 'supersu namespace separation'. I use SuperSU as root access management tool on my device, which has an option for "namespace separation". I missed the point that this option must be disabled for my firmware.

  1. Open SuperSU application (if you don't have it, then the solution is not applicable to you)
  2. Go to Preferences tab
  3. Scroll down to 'Namespace separation' option and uncheck it
  4. Reboot the device.

This solved the issue on my device.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.