1

I have a Moto G 4g (peregrine XT1039), which in every one or two days reboots to bootloader with "Fastboot reason: failed to initialize partition table", see Image(1).

In Image(2), you can also see "Device is LOCKED" on the photo, but I've unlocked it as you can see when I rebooted to bootloader manually.

(Click any image to enlarge it)

fastboot reason: failed to initialize partition table IMG: Unlocked bootloader

Image(1)                                                      Image(2)

I was using CM12 but tried to solve this by flashing a stock image following this thread. I also tried to solve this by replacing battery with a new one, but it didn't help. I think my device is defective, but I lost my warranty unlocking it and replacing battery.

Does someone know how to get rid of these reboots?

0

2 Answers 2

1

I know that the thread is old but for other people it can help a lot. I had nearly the same symptoms and i found a reason why my phone dont wanted to start again. In my case it was the battery: https://forums.lenovo.com/t5/MOTO-G-MOTO-G-4G-LTE-1st-Gen/Solution-Moto-G-4g-LTE-random-shutdown-2-4-times-a-day-and-after/td-p/3446925

1
  • in my case I've tried with a new battery, no luck
    – Lluís
    Oct 5, 2016 at 22:26
0

Many Motorola phones with an unlocked bootloader show they are locked because people flash a file to make it LOOK locked, not really sure why but many unlocking instruction tutorials online even include this as a step.

But to your core question, it sounds like your internal storage is corrupt (or worse, possibly failing), or the partition table is corrupt. You should first flash the latest factory firmware image for your specific device/region (available here) and make sure to follow the instructions EXACTLY including the factory resets and all sparcechunks or bricking is possible. Although it is not mentioned in the instructions on that page, it is highly recommended that you factory default before flashing the factory image.

Once the device is back in completely stock condition, try it for a couple days to see if the problems continue... if not, reflash CM... If the problem recurs, you likely have a flash module that is failing and it is not a replaceable component and it would be time to start looking for another device.

2
  • iirc I've tried to flash stock firmware, but didn't work, in fact I've bought new phone some months ago
    – Lluís
    Apr 2, 2016 at 11:45
  • Lol... I missed the posting date, hate how edits bump it up into the active questions. Sorry for the late answer.
    – acejavelin
    Apr 2, 2016 at 12:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .