0

I know similar question is floating on the same site, but no solution works for me.

I have been using Karbonn A26 Smart phone for the last two years, and I was not able to install run YouTube and Google+ since 2 years. Its hardware is quite ok. It runs Android 4.1.1.

Let me be clear what I am doing:

  1. When I install and open YouTube, it says YouTube cannot work without Google Play Services. When I click on Get Play Services, it gives me error: "Incompatible with other applications(s) using the same shared user ID".
  2. So I factory reset the phone. Then I try it out, same. I can download and install YouTube, but when open it, it keeps saying same "Cannot play without Play Services".
  3. Same thing happens when I install and run Google+.

Installing YouTube on clean OS itself does not work.

Do I need to wipe cache? I think factory resetting must also wipe cache. What should I do to resolve this issue?

3
  • bro they all ask to factory reset. But this does not work for me, neither I am rooted. – Maha Jul 12 '15 at 15:29
  • Whether you are rooted is a different issue. But what you forgot to mention: Do you have the Google-Apps already installed on your device? Can you e.g. use the Google Play Store app? If not, please see How can I install the Google Apps Package (Play Store, …) on my Android device? – Izzy Jul 12 '15 at 16:30
  • Whether I have Google-apps installed? Well I had only play store installed and it just works. But then I tried installing gmail, Google+, YouTube, all say Get Google Play Services, when I click on that, installing Google Play Services fail with above error. Also I checked, in Settings > Apps > All, there is Google Service Framework, is it the Google Play Services? – Maha Jul 12 '15 at 17:15