Whenever I plug a USB cable into my Samsung Galaxy S5 device, it won't show the USB icon, I don't see anything happening on my computer either, all that shows is that it's charging.

I tried plugging another android device into the same usb cable, and that works, so I conclude that there is a problem with my device.

I tried rebooting my device into download mode and then plugged the usb cable in, and suddenly my computer reacts!

Is there some setting that I've made that could block the device? I've set and unset USB debugging (I have been able to load apps from Eclipse earlier) but that didn't make any difference.

I heard that someone with similar problems solved it by reflashing the device, is this necessary? I would like to avoid that if possible.

  • I switched cables and it works. Its really finicky I find I have to switch cables/ports every few months or so.
    – chiliNUT
    Commented May 3, 2016 at 17:16

9 Answers 9


Type in your dialer *#0808# and choose MTP+ADB and save it.


I was having the same issue so I attempted the Settings > Storage > Settings but there was no 2nd settings listed under Storage. Instead, I found the MTP someone mentioned by doing the following: Apps > Settings > Developer options > (Scroll down to the Networking section) > USB configuration > (select MTP(Media Transfer Protocol)). You will get a pop up on your phone that says: "Allow access to phone data. An MTP connection will be established to access the data on the connected device." Just hit Allow. After doing this I got a pop up on my desktop for the usual options of a media device and this time when I clicked on "Open device to view files" it actually worked. I was able to access sound clips, videos, photos, you name it.

Another thing to note is after I disconnected my phone from the computer and tried again I had to go through the menus again and set it from Charging to MTP.

Also, if you don't have Developer options go to: Apps > Settings > About phone > (tap on Build Number several times until it unlocks the Developer options). Now the Developer options should be right above About phone.


Go to Settings › Storage › again settings (on action bar). There should be "USB Computer connection" option. Tap on it and choose "mtp mode". That should make your phone visible to your pc.

If it won't help - let me know!

how it looks with my device
Screenshot (click to enlarge)

  • 1
    I have no such options under "storage" as far as I can see, I also tried searching in settings for usb and media without luck.
    – Mårten
    Commented Jul 13, 2015 at 6:55
  • this didn't work for me. I have no further "action bar settings" after going to storage. I was able to get there doing a search for USB in the setttings search.
    – chiliNUT
    Commented May 3, 2016 at 17:17

Reflashing the device is overkill for this me thinks - When you plug your device in, can you see it in your device list in Windows? (Search for "Devices and Printers", or go to Control Panel > Devices and Printers)

If Yes: Try a different USB cable. I've owned several Samsung devices and they're picky about USB cables. Try to use the one that came with the device, if possible. If several cables don't work, or you don't have an extra (and it has worked before), try the No steps below.

If No: Make sure you have the SAMSUNG USB Driver for Mobile Phones installed, it should be in your Programs list in Programs and Features (Search for "Programs and Features", or go to Control Panel > Programs and Features). When your computer reacts to the device in Download mode but not while it's running tells me you may only have the Android ADB drivers installed. You can obtain the drivers here. If the driver is there, try re-installing it (and make sure you use the newest version, such as the download from the Samsung website that is linked).

  • Nope, it's not in the device list. I ran the samsung usb driver installer twice, the second time I noticed an easily missed "driver not installed" text, not sure if it was there the first time around. The files are in the right folder, but there is nothing under "Programs and Features". Anyway it still won't react, it doesn't even show up in the device manager. I think I'll reset the phone and see if that works.
    – Mårten
    Commented Jul 14, 2015 at 5:51
  • Give it a shot, I'm not sure where to go from here other than contact an Authorized Samsung Repair facility if it's under warranty. If you do decide to go that route, DO NOT reflash the phone - this can set the warranty bit and give them grounds to refuse to fix it under warranty.
    – ZeroPaladn
    Commented Jul 14, 2015 at 12:03

This is a fix if you are having trouble transferring pictures and video to you computer from a Samsung Galaxy S7...it might work on a S5 too. First go to Settings, then System, then click on developer tools, turn on developer tools, scroll down to USB configuration...click on it and select MTP. Mine was stuck on "charging". Took several times of going in and out to select MTP. Then reboot device. I then could transfer pictures to PC again. Be sure to turn back off developer tools when finished selecting MTP.


I have search my phone high & low and discovered that Developer option no longer appears on my Galaxy s5. I finally got the USB screen to appear only when I used the original Samsung cable.


I have a few things I tried to get to see the photos AND videos on a Samsung Galaxy S5 when connecting by USB to a Windows 10 PC:

  1. Plug in the USB cable
  2. If you are lucky a window will pop up on your pc. If things are normal (i.e. poor) it will not show any of your images or even folders.
  3. Swipe down from the top and there may (if you are lucky) be an option for USB behaviour: set it to "File Transfer"
  4. That should work but normally doesn't
  5. Go to Settings
  6. Select Developer Options (near the end)
  7. Turn on Developer Options
  8. About halfway down in the Networking section, there is an option "USB configuration" - set this to MTP. Most times it doesn't change from "Charging" but be persistent. Untested, but this might relate to setting in item 3
  9. Go back to Settings main screen
  10. Use the search at the top for "USB"
  11. Select USB configuration and if you are lucky, you will get a list of options from which you will choose MTP. If you are less lucky, it will dump you into Developer Options, which you have set in 8 above.



Okay had exactly the same issue changed the USB cable and the option appears it seems that not all USB cables are the same some must be USB 2 or 3.


To get the USB icon, go to SETTINGS → Developer Options → Debugging and then select USB Debugging.

  • This appears to be incorrect. The USB icon here referred to by the OP has nothing to do with USB debugging. Its just the icon on the device which shows that the device has been connected to a computer. Commented Apr 5, 2016 at 5:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .