1

Yesterday i've decided to check some of the custom ROMs for my Sony Xperia Acro S. With locked bootloader i installed a CWM Recovery and flashed a ROM.

The ROM Worked and the signal worked and i've made few calls to check if it is working or not.

i decided to check another ROM, it caused a bootloop. so by using the Flashtool i flashed the stock ROM again and installed the recovery again and flashed the first Custom ROM again to check it out more.

Sadly, the mobile says "Emergency call only" and " No SIM detected ". i tried the SIM card on another phone and it's working.

so, i flashed the STOCK ROM that i used to flash many times and it should be 100% working, but NO, The problem is still there.

when i check for the IMEI number by the * # 06 # it says "no newtork connection "

I Can't find a solution online, so please help me.

TL;DR

Things i have made before the problem:

  1. Flashed a Custom ROM had a bootloop, Flashed the Stock ROM and then Flashed another Working Custom ROM.

Things i have made trying to FIX:

  1. Flashed the 4.1 Stock ROM.
  2. Flashed the Old Android 4.0 ROM and updated it via Sony's PC Companion.
  3. Checked the IMEI Number = fail to find and it says "No Network Connection"
  • look under settings > about phone search for modem version or radio version ,tell me whaat it say – lord-ralf-adolf Jul 13 '15 at 23:26
  • I Can't find " modem version or radio version", but here is an album of screenshots of my "settings > about phone" : imgur.com/yIxlCej,ZpVp51n,1KkVQgz – Sherif Abdel-Naby Jul 14 '15 at 0:39
  • and here is the #*#INFO#*# Screenshot : imgur.com/J0EN10S – Sherif Abdel-Naby Jul 14 '15 at 0:50
  • yes my apologies on sony it's called "baseband version" I am currentlly reading more about your device will be back in a few – lord-ralf-adolf Jul 14 '15 at 0:51
  • is your phone bought unlocked or did you unlocked it ? I am talking about the simlock not the bootloader – lord-ralf-adolf Jul 14 '15 at 1:24
1

EDIT: This fix was temporary. The problem returned the next day. Sorry.

After I flashed Cyanogenmod 12.1(upgraded to lollipop) to my nexus 5 I had the "no Sim Card". It is a very popular problem for this ROM or Lollipop in general. I try shimming the sim, Updating PRL etc... and nothing was working.

Here is what I think finally fixed it for me:

In dialer keypad: *#*#72786#*#* (this will wipe the carrier settings)

reboot if your phone didn't automatically. Your phone will go through activation in about 5 minutes, re-gathering the correct carrier settings just like when you first bought it.

Tip was found here: https://help.ting.com/hc/en-us/articles/205428508-Completing-Activation-for-Your-Nexus-5-or-6

Hope this helps someone, anyone.

  • Did not work for me on Xperia SP, even temporarily – Alexandre Bourlier Jan 23 '16 at 18:55

protected by Community Dec 15 '16 at 0:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.