0

I recently (dumbly) removed my internal through TWRP on my Asus Zenfone 2 whilst trying to flash SuperZen from xda. So now I'm attempting to go back to stock, and I've tried doing a factory reset with the stock recovery, but with no luck. I'm currently trying to flash boot.img, recovery.img, droidboot.img and system.img via fastboot on Linux and Windows, but I get:

$ fastboot flash system system.img

target reported max download size of 536870912 bytes
erasing 'system'...
FAILED (remote: Permission denied)
finished. total time: 0.136s

for each one. This is when trying to flash using version WW_2.19.40.22. The interesting thing is, is that when I flash twrp.img or recovery.img(stock) it still gives me that same error, but when I boot into recovery, I have either TWRP or stock recovery, which shows that it did work. Sadly, this is not the case with system, so if I reboot into the system, it does not work properly and hangs on the "Powered by Android" splash screen.

EDIT: just tried using fastboot update -w Zip_Name.zip and it gives me:

archive does not contain 'android-info.txt'
archive does not contain 'android-product.txt'
error: update package has no android-info.txt or android-product.txt

EDIT 2: booted into TWRP and used "Install" to try and flash the .zip I put on the SD card, I got the logs copied to the SD, and here is the relevant section:

minzip: Missed a central dir sig (at 0)
E:Zip file is corrupt!
MtpServer::run fd: 13
E:request read returned -1, errno: 5, exiting MtpServer::run loop
Error flashing zip '/external_sd/UL-Z00A-JP-2.19.40.21-user.zip'
Updating partition details...
I:Data backup size is 0MB, free: 55424MB.
...done

Basically, it gave me E:Zip file is corrupt! and ended up with "Failed".

  • do you have an sdcard or a way to put system.img on your phone internal memory ? and if you have access to adb from the twrp ? – lord-ralf-adolf Jul 14 '15 at 22:53
  • I do have an SD card, I forgot to mention that I also have a nandroid backup that I may be able to flash. – nixpower Jul 14 '15 at 22:55
  • one more quetion ,why are you flashing every img separatlly ? don't you have the stock zip rom ? – lord-ralf-adolf Jul 14 '15 at 23:00
  • Do you think that will help? I just grabbed one from here – nixpower Jul 14 '15 at 23:02
  • of course it will ,at least I think so try using this command after booting your phone in fastboot mod and pluged to PC the command: "fastboot -w update "name of zip file" while the name of zip is the name of the zip firmware you downloaded – lord-ralf-adolf Jul 14 '15 at 23:08
1

To solve you problem execute the following :

  1. Boot your Phone into TWRP Recovery.
  2. Plug your phone to PC and make sure it is recognized by adb you can run adb devices command to check.
  3. on you Phone TWRP go to wipe > advanced wipe check data ,cache and system then swipe the swipe zone in the bottom
  4. Now go back to the home of TWRP and navigate to Advanced >> ADB sideload swipe where it is written Swipe to Start Sideload
  5. go to you PC and fire up a terminal or a cmd (depend on your operating system) and type this command adb sideload path/to/you_firmaware.zip
  6. Your phone will start flashing the zip wait until it's done and then reboot your system.
  7. the first boot may take awhile be patient.
  • Switched my SD card and I found out the root of the problem was the SD card reader, changed that and it no longer corrupted the zip. I'm back up and running now after flashing it through TWRP, but because this will most probably work to fix this issue as well, I will Accept your answer. – nixpower Jul 15 '15 at 2:52
  • Glad to hear that ,I answered with adb sideload method when I saw the log showing file system errors ,adb sideload will work even with no SD card – lord-ralf-adolf Jul 15 '15 at 2:56
  • I was having some issues with sideload when I tried it prior to flashing with TWRP, so it may not work and you might need an SD card regardless. I know I'm not getting a device that doesn't have an SD card slot! – nixpower Jul 15 '15 at 12:45
  • I have an HTC one ( no sdcard ) and I use adb sideload normally – lord-ralf-adolf Jul 15 '15 at 14:00
1

I have answered a similar question here: Fastboot permission denied error in Asus Zenfone 2

Basically, you just need to remove all pin/pattern unlock on your phone first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.