I installed CM12.1 on my Samsung S3 mini and realised that there's no FM radio app. So I extracted it from the stock backup and tried to install it but the operation ended with a message "app not installed".

I would like to know why wasn't the app installed. Is it because the system lacks a driver? Is there some dependency requirement? This is the first step to diagnose the issue.

  • 2
    To answer that for this specific app (and not just give "possibilities why an app might fail to install"), we'll need some more details. Usually, a "logcat" is helpful here (see our logging tag-wiki if that word doesn't ring a bell). You probably can investigate that yourself, it usually points out the reasons pretty clear.
    – Izzy
    Commented Jul 15, 2015 at 7:38

1 Answer 1


In Cyanogenmod ROMs there is no Radio app that comes with system.

When Stock Radio App was created there was no Android Lollipop, latest was JellyBean 4.1.2. Things and workflow in Lollipop was changed, so JellyBean Radio App is not compatible with Android 5.1.2.

Without code change and debug-able version, you can't make it work, because you can't see what is problem, and what to change. And you will not get it because it is closed source...

Best way to have radio app on your system is to install app called SpiritFM. I know it worked on Novafusion CM 11 - 4.4.4, but I'm not sure for CM12.1, but you should give it try.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .