3

I just bought a Sony Xperia Z3 Compact (D5803) and I'm trying to root it. I'm following this link for instructions, but I got stuck at the "Rooting with exploit" step as I can't authorize the connection.

I've already tried:

  • Restarting the ADB server
  • Rebooting the device
  • Rebooting my PC
  • Changing from MTP to MSC and back
  • Disabling and then enabling USB debugging
  • Disabling and then enabling 'Developer options'
  • Using various ADB drivers
  • Using different ADB binaries
  • Deleting my .Android folder
  • Deleting ADB copies in other tools' folders
  • Plugging the device in another port
  • Any combination of the above that I can think of

I can't find any other possible solution to this issue on Google. I'm hoping you guys will be able to enlighten me and finally be able to solve this.

PS: Something tells me that my PC is the problem here, as I was never able to do this with my old SGS3 either, but I ran out of ideas about what could be causing it anyway.

  • It might sound stupid, but you might consider seeing if your device is recognized by adb in other computer. If yes, you might proceed with reinstalling the os(windows/linux) on your PC. I once had problem with Xperia P, I had to reinstall windows. – Shamsul Arefin Sajib Mar 28 at 4:54
0

This helped me, before step 13 "Enable USB debugging on the phone (Settings => About phone => Click 7 times on Android Build to unlock developer options)" make sure you have enabled MTP over USB on the phone. Sometimes it helps to revoke the approved debug devices as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.