I have a Nexus 7 2012 wifi. With the latest version of Lollipop it has really become unusable, freezing for a minute or more, or even rebooting while loading a page in Chrome.

I did a system reset, but that did not change much past the few first minutes.

What is the recommended version to have again a usable tablet? Is anyone having a "runbook for dummies" to install Android 4.x (or CM or whatever works fine) ?

Most of the tutorials I found on the Internet are for geeks wishing to experiment. I just want a running system with minimal fuss/risk.

  • 1
    Found this thead that seems to recommend Android 4.4.4or CM11. I'd love to have some confirmations...
    – iDevlop
    Jul 15, 2015 at 19:35
  • 1
    I second the 4.4.4 downgrade - it was the last version that had no horrible usability challenges with that old Tegra 4 processor, and it's one that I've personally downgraded to on my device.
    – ZeroPaladn
    Jul 15, 2015 at 19:56
  • What "versions" of Lollipop are you using? I use MultiROM and have 6 different ROMs installed. 2 are Lollipop, 5.0.2 and 5.1. Both run without incidence. Have you tried wiping cache and dalvik-cache from recovery? A better question would be : are you sure your installing the device correct ROM? (There are 2 different 2012's - WiFi only (grouper) and the 3g/WiFi (tilapia)). They will install to each other but will cause corruptions and compatibility issues. I mention this, because Lollipop works really nice on this device.
    – HasH_BrowN
    Jul 19, 2015 at 16:52
  • @HasH_BrowN I never "tweaked" it. It got its 5.1.1 OTA. For me this is a consumer device, it should just work, without requiring me to spend time studying what's under the hood. I did wipe the cache, but I have no clue what's the dalvik cache.
    – iDevlop
    Jul 19, 2015 at 20:07
  • You would have to go into recovery and wipe the dalvik cache there. Most of the time after installing a ROM, even an OTA, the cache and dalvik cache need to be wiped otherwise the issues you been having arise. Do you have a custom recovery installed (CWM or TWRP)? Your accepted answer deals with a custom ROM, which needs a recovery to install.
    – HasH_BrowN
    Jul 20, 2015 at 7:11

6 Answers 6


You can use the highly functional nexus root toolkit to do pretty much anything you need to on your Nexus device.

Nexus Root Toolkit

It allows rooting, return to stock, recovery and everything else you would need to repair your nexus 7 2012 WiFi aka 'grouper' / 'nakasi'. You can flash custom roms with it also.

Nexus Root Toolkit v2.1.0

Other tools include unlocking or locking the bootloader, adb tools, driver installs. .. you name it, it does it.

Advanced Utilites

Works with all nexus devices released so far.

Select Nexus device and ROM

One of the most handy things about it is that it tells you what to do step by step...

Instructions for installing drivers

Every nexus owner should have this as it's pretty much indispensable.

  • I have the same nexus 7 as you, and this tool has been so very useful.
    – user115074
    Jul 16, 2015 at 13:51
  • After trying "lighter" solutions, I ended up re-flashing my Nexus to 4.4.4 with Wugfresh, and I must say that it worked flawlessly. Advice to others: plan for 2+ hours (the first time) and even rebooting your PC. Have some coffee and a good book available :-)
    – iDevlop
    Aug 2, 2015 at 9:12
  • Also: I had the feeling that Nova launcher makes the tablet a bit more responsive
    – iDevlop
    Aug 2, 2015 at 9:17
  • Yeah nova launcher is pretty good! Glad you got it fixed :)
    – user115074
    Aug 2, 2015 at 9:31
  • I found out that now my 32GB Nexus is displaying 8GB memory. This is evoqued here: android.stackexchange.com/q/97169/67779
    – iDevlop
    Aug 2, 2015 at 9:35

The official Google Developers site has the full instructions and image repository on how to install a factory image for any Nexus device, including your "nakasi" Nexus 7 2012. I recommend 4.4.4, but you are free to go back as far as you want until you're comfortable with it's use.

Cyanogenmod also has a stable 10.2 version (Android 4.3) - you can download the image file here. You can re-use the instructions found on the Google Developers site to install this as well (just target your CM unzip location instead).

BE AWARE: This will wipe your device, and this is all done under your own volition. Flashing a device - regardless of source or instruction - always comes with risk of damaging or rendering the device useless. We are not responsible for it!


Try 'JimTDI's Guide - Tuning the Nexus 7 with Android 5 Lollipop for Maximum Performance!' here https://goo.gl/X0HwAu The discussion for this post is here https://goo.gl/wqjv76

  • very usefull, this helped me understand a few things and helped making the machine more usable. I also installed Nova launcher, which made it faster (my feeling), without spending half a day doing risky things I don't master.
    – iDevlop
    Jul 19, 2015 at 20:11

Old question, but this is my beloved Nexus 7 3g (2012), "tilapia". Please note that WiFi only version is named "grouper"

First step, install TWRP recovery; the official guides forgot to mention that you have to disable the fastboot lock too, command: fastboot oem unlock (and then select Yes on the confirmation screen, on tablet)

Nexus 2012 TWRP installation details here

Then I have installed on my Nexus the Android AOSP (vanilla 7.1.2. andorid) with tilapia/grouper support released by AndDiSa on XDA forums. Main thread is here.

Now it works really fast, I can use the web browser, play and see movies with no hiccups.

I quote my "success story" form XDA forum:

I have successfully installed the aosp_tilapia-7.1.2-ota-eng-20181112.ds.zip on my Asus Nexus 3g 2012 (tilapia), I also installed open_gapps-arm-7.1-pico and Magisk v17.3. I installed your Android release, by using TWRP-3.2.3-0-tilapia, over the Asus original fully updated Lollipop. In fact the most tricky part was installing TWRP

During installation the initial OS configuration failed, multiple times (I tried with reboots), just during the user account selection. Using the suggested SetupWizardFixCrDroidNexus7.zip fix, fixed the problem, and I was able to complete the device configuration.

Finally: My Nexus is back to life, is very responsive, browsing and playing movies are very fast... I have not tried all the functions (not tried camera yet).

With official Lollipop my Nexus was simply unusable, u-n-u-s-a-b-l-e, I used to think that my beloved Nexus was simply too old for the new applications. I think now that Asus(or Google, is a Nexus) released defective OS versions for manufacturer-planned-obsolescence

  • Interesting. I still have that tablet (unused). I might give your solution a try. Is it feasible for a non specialist ?
    – iDevlop
    Nov 20, 2018 at 9:55
  • It depends, there are passages (TWRP installation) for sure where technical experience helps to not get stucked. i.e., you need fastboot and adb commands, -> so you have to install Android-SDK -> to invoke its adb/fastboot commands perhaps you have to invoke them from command prompt from the right path, I have no Windows OS but Linux, you must certainly try and try again, more times. And for sure you need 1)Patience 2)Method. I think that with no mistakes an expert guy needs about an hour to make the job done. But I cannot say exactly what the minimum level is.. I'm sorry. Nov 20, 2018 at 10:12
  • 1
    Added my TWRP guide link, thegoodcodeinn.blogspot.com/2018/11/… Nov 20, 2018 at 10:14
  • I try: I think that an average programmer can make the job done. Nov 20, 2018 at 10:17

What I did to improve performance on My Nexus 7 2012 (Nakasi) was to Unlock Bootloader then flashed TWRP v3.3.0, then flashed Lineage OS 14.1 (Android 7.1.2 Nougat) via TWRP, Recommended GAPPS are "opengapps pico" (arm) and to root it I flashed Magisk v18 and now it took life. Performance improve like 90% now is pretty much usable. (it's April 16 2019) so belive me when I say it is usable and performance wise is awesome.

  • interesting, thanks. Could you eventually the necessary links ? Thx !
    – iDevlop
    Apr 16, 2019 at 11:08

I recently got my Nexus 7 2012 usable and fast after 2 years resting in a drawer with rooted Lollipop using suggestions from this site (in Spanish) like disable all gestures at Language Input/Gboard and disable graphic animations in Developer mode.

  • Looks interesting, thx. I'll give it a try
    – iDevlop
    Dec 6, 2019 at 7:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .