3

I recently added a couple of ringtones and notification sounds to my phone by placing them into my storage's Ringtone and Notification directories respectively, and I can select them from the sound settings dialogs without any problem.

The thing is that they also appear as songs on my Google Play Music's playlists, and of course I don't want to hear a 1 second long "jigglypuff!" notification sound every now and then when I'm listening to my music on shuffle.

I did search using Google for a while but it seems that there's no way of either removing the file from just the music database or from excluding those directories from the media search. I recall this didn't happen on an old 4.0 Sony Xperia phone I had with it's music player.

  • In which folder did you save your local music on the phone ? – Bibz Jul 16 '15 at 20:21
  • It's either on the music or the downloads directory – arielnmz Jul 16 '15 at 20:36
1

Hello everyone and thank you for your answers, I've finally managed to accomplish this with a very simple solution: The Android media storage service will not index media files inside directories which are hidden (preceded by a "."), but also those which contain a file named ".nomedia", so I just created on all the directories I wanted to exclude and that was it. Hope it helps somebody else.

P.S.

I didn't want to hide the entire directories since they're my phones ringtones and notifications directories and I still want them to be visible to the sound manager to use them, I just don't want them to be seen by Google Play Music.

I found the solution here: http://www.guidingtech.com/15563/hide-certain-files-android-music-player-photo-gallery/

  • According to discussions here, the .nomedia option may or may not work anymore, and it may or may not require reboots and turning on/off the Downloaded only option. – Travis Bemrose Sep 7 '16 at 3:50
  • The .nomedia option appears to have worked for me after a reboot. (I did several other things at the same time, but that's likely to be the minimum it needed.) – Travis Bemrose Sep 7 '16 at 3:51
0

I may not be able to help you 100% with this, but I had a similar issue when storing audio books on my SD card. What I did was made a folder called .audiobooks The . In front made it hidden from Google Play Music. Now, I'm not sure if in your situation this will hide it from the system for ringtones.

  • The system is no longer able to find them by using dot directories – arielnmz Jul 16 '15 at 20:38
0

See: How do you prevent Google Music from importing all .mp3 files on the device?

Make the folder hidden by putting a "." In front of the folder name, like: .audiobooks instead of audiobooks

or make use of the .nomedia files.

  • I thought of that too, but I'm wondering wouldn't that make the Ringtone and Notification directories be ignored by the Android under Settings too? I would bet on yes since Mediaserver keeps the databases of all sound files including the Ringtones and notifications used by Android Settings. – Firelord Jul 16 '15 at 20:24
  • That's right, they won't show on the system's menu now – arielnmz Jul 16 '15 at 20:56
0

In case of notification and alarm sounds you can save them in the Notifications and Alarms folder on you device and they won't show. The folders should already be there.

If it's other audio file Madelin's and user31's answers should be good.

  • They're already there, and Play Music still adds them to the library – arielnmz Jul 16 '15 at 20:37
0

Placing a '.' in front of a folder prevents google play music from loading songs into the app but prevents you from using the ringtones inside of the hidden folder for default alarms and ringtones.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.