2

I have a crazy problem. Whenever I update anything I get this error

update for (insert Google app here) could not be downloaded due to an error (error while retrieving information from the server. [RPC:S-7:AEC-7 QNHM-TYSO-UNVHY])

It may also be worth telling you the very last 5 letters vary. It also happens to any new apps I attempt to install.

2

You're going to want to clear the cache of your Google services on the device. Note that this will remove your Google Account from the device - so you'll have to re-add it.

  1. Navigate to Settings > Applications > Manage Applications > All
  2. Clear the data for Google Play Services, Google Service Framework and Google Play Store
  3. Reboot the device
  4. Log back into your Google Account
  5. Try your downloads again
  • OK. That has worked, and I'll mark you as the answer after you tell me why the only app with a problem is the store? I get instant "no connection" with WiFi on, even tho GH the hosts file is fine – Dan Brown Jul 18 '15 at 9:41
  • After repeatedly trying your method, it worked! Marking as answer ;) – Dan Brown Jul 18 '15 at 10:30
4

This error can have multiple causes. Some are explained on our sister site, in Error while retrieving information from the server RPC:s-7:AEC-0 in Google play?:

turns out my credit card info on file needed updated to my new expiration date.

is one possibility. One more:

RPC:AEC:0 error is known as CPU/RAM/Device/Identity failure.

  1. Go to settings >application > Play Store >Clear Data & Clear Cache.
  2. Go to accounts >Google >Remove account.
  3. Reboot device.
  4. Again Settings>Account >Google >Log In.

Another reason is explained on AndroidPIT (German): It could be problems with Google servers (same is, btw, reported by users in this thread on AndroidForums.Com). One user reported a work around that did it for him: He tried it at least 10 times on his Android device, without success. So he simply fired up the browser on his computer, and tried it from there -- which immediately worked.

For more details (and possible other solutions/work-arounds), just follow the other results from this Google search.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.