I've tried everything on the internet to root my phone and followed the exact procedures – but when I try to install CWM or .tar files through Odin mode, I seem to always lose my recovery mode:

Pressing volume up + home button then power button won't work to boot to recovery mode. It just displays a very small red exclamation point at the topmost left of the screen and the logo at the center of the screen then it will turn black, then back again at the logo with the (!).

I still can open my phone but can't boot to its recovery mode and still not rooted. Good thing, there is a way to recover my recovery mode by reflashing my Android's stock ROM through Odin mode, which works 100% in reflashing back my recovery mode. I do, still, have to factory reset my phone after reflashing through the newly flash stock ROM.

Now the question is, how can I ever root my phone?

  • how about trying with king-o-root....though the device is not listed....but you can give it a try kingoapp.com/android-root/download.htm – Jasser Jul 18 '15 at 17:22
  • Tried that already. I've also tried Kingroot and Vroot (now Iroot) both are of Chinese origin but they still can't root my android. They're harmless somehow to use on my android. These one click rooting apps don't actually root your device, they're just taking over the official root of your android if your android is already rooted then verify it. – Rukino Jinsen Jul 18 '15 at 17:51
  • I am talking about the PC version of king-o-root. It worked perfectly fine for my samsung galaxy-S-duos GT-S7562. I also verified the root two ways.. – Jasser Jul 18 '15 at 17:54
  • I think that will take too long to download on my computer. I've also tried Iroot PC version but failed again to root my phone. Should I try other PC versions of some one click rooting apps? These PC versions of rooting android also come with other apps that automatically install while rooting. – Rukino Jinsen Jul 18 '15 at 18:03
  • We'll its just around 30 mb....since that method worked I haven't tried other methods to root.... maybe others here can help..... – Jasser Jul 18 '15 at 18:07

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.