1

My Android device used to be properly rooted, I had root access to things, but the root manager (old version of vRoot, no computer) was a virus. So, I deleted the root program and I was gonna root another way, but I can't delete the old su binaries. I was gonna try and use something like Odin and TWRP to root, or perhaps another method. I have a Samsung Galaxy Tab 3 7' Wifi Only (SM-T210).

How do I delete the SU binaries without root? Maybe using adb? I do not have fastboot.

  • are you open to flash custom recovery ? also try to install SuperSU from the play store open it if it ask to update su binary say yes and choose normal method ,see if that updates you su binary or not – lord-ralf-adolf Jul 19 '15 at 20:04
  • @lord-ralf-adolf I can't. I tried to update the su binaries through supersu and it said that it failed. Also, I tried to flash TWRP through Odin, but it didn't work. – Gab3 Jul 19 '15 at 22:47
  • it didn't flash the TWRP ? you have truble flashing TWRP or you did flash but you din't figure a way to use it to remove the SU binary ? – lord-ralf-adolf Jul 19 '15 at 23:15
  • @lord-ralf-adolf It didn't flash the TWRP. I booted into recovery (with ADB) and it was my usual device recovery. That is meant to root the device by installing the SU binaries but I had the 2 problems. 1. TWRP didn't flash and 2. I still had the old SU binaries. Should I flash the stock firmware? Or will that still keep the bin and xbin folders from /system – Gab3 Jul 21 '15 at 7:07
  • so you wanna delete the su binary so you can root again ? your problem is how to regain root access right ? – lord-ralf-adolf Jul 21 '15 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.