1

I have a Samsung Galaxy S4 running Android 5.0.1. I don't know the last time I tried accessing the phone with my computer but it worked using MTP.

Now I struggle enabling MTP. The phone prompt (asking for MTP/PTP) won't appear. I double checked it with another PC so the USB port doesn't seem to be the problem.

I followed this little answer but I don't have the three dots (aka context menu) on storage settings.

My PC is running Linux. But I don't think this is the problem as the phone prompt does not appear and the device is not even recognized (no /dev/-entry). But to be sure I additionally installed mtpfs and mtp-tools just to be sure. But it didn't help.

Oh. I'm using encrypted device with encrypted SD card. Does this disable MTP at all?

  • 1
    possible duplicate of Disabled MTP, cannot access setting to enable -- no answer as of yet. – Firelord Jul 19 '15 at 16:49
  • Have you tried toggling USB debugging? (It may sound irrelevant, but there is a slight chance it will shed some light on the subject) – Avia Efrat Jul 19 '15 at 18:50
  • @Avia yes, I tried that while I tried if it works with USB debugging disabled. – Bertram Nudelbach Jul 20 '15 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.