2

I'm trying to flash CM11 firmware on a GT-N5100 device. I installed the custom recovery (tried both CWM and PhilZ), and while flashing it says I'm on a wrong device. On CWM, it was saying "The package is for N5100 and you are in a N5110, update aborted".

And on PhilZ, it says "This package is for kona3g, kona3gxx and you are on a konawifi, operation cancelled."

Now what am I supposed to do? I'm unable to install CM11??? So sad.

1

On comparing the models, there is difference between the two (especially when it comes to network). I suggest that you do have a look at this before proceeding and try that first. But if you are sure that your model is N5100 and still want to try and proceed, there is a workaround you can do so it doesn't check/compare the models.

  • Open the ROM zip file with winrar.

  • Go to META-INF/com/google/android and open the updater-script with notepad.

  • You are looking for line similar to:

getprop("ro.product.device") == "N5100" || abort("This package is for \" N5100\" devices; this is a \"" + getprop("ro.product.device") + "\".");

(this line should in fact be the very first line in script).

Erase this line, save the zip and flash again. It won't verify your model.

Warning: I am not really a Samsung user. So I am not aware of its models and naming conventions that much. Make sure about models otherwise you may end up bootlooping your device or having other problems and having to flash firmwares over again (you can ask on xda itself about this).

Hope this helps ;)

  • Thanks. I found another way to bypass that verification by seeing a specific tutorial on YouTube which uses TWRP instead of CWM. It worked perfectly. The only harsh that surprised me when someone called me was that there was no audio in or out at all. I'd ask for a workaround for that here, but I guess I'll have to ask that in another post. The Snapshot I flashed is from the last year. But even that I may be afraid, I guess I'll have to try the latest nightlies. Thanks again. – K0media Jul 20 '15 at 0:40
  • I found it. Just followed this little guide (forum.cyanogenmod.org/topic/…) and it worked fine. Now I'm very happy with the brand new rom. =) (At least so far.) – K0media Jul 20 '15 at 2:16
  • along with that file and line, the META-INF/com/android/metadata file might have device whateverthedevicenameis. – ILMostro_7 Feb 5 '18 at 10:16
1

The device model is hard-wired into the recovery image. Make sure that you have flashed the right recovery image for your device.

E.g. TWRP lists the recovery images for both N5100 and N5110 on the same page. If you accidentally flash the wrong image, the device will still boot in TWRP recovery (the hardware differences are minimal). However, you will have problems flashing the right image for your device.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.