4

I have a Oneplus One running CyanogenMod 12.0. (Based on Lollipop 5.0) I'm trying to create a backup using ADB. I executed the command, and it gave me the usual prompt to unlock my phone and allow the backup. On my phone, the screen comes up asking me if I want to encrypt the backup with a password, and with the "Do not back up" and "Back up my data" buttons. So far so good.

The "Do not back up" button works fine: When I click it, the command on my computer stops running. But the Confirm button just does nothing. When I tap the button, nothing happens; the button doesn't even "light up" like buttons normally do.

  • The button is not "grayed out" or disabled: It looks exactly like the other, functioning, cancel button.
  • I tried inputting a password, thinking maybe it would not allow me to back up my data unencrypted, but it still behaved exactly the same
  • I tried running the "adb backup" command with literally every combination of arguments, with the same results
  • "adb devices" does show my phone properly connected

How can I either

  • Fix this, and make an ADB backup
  • Make a complete backup in some other way, without root access. (I want to unlock my bootloader, which wipes all data)
  • 1. "When I tap the button, nothing happens" -- so what exactly happens on computer's screen when you tap "Back up my Data" button? // 2. Does the command exits abruptly like when it does for "Do not back up"? // 3. Did you ever create Desktop backup password from Developer Settings of Android some time earlier when using the device? – Firelord Jul 21 '15 at 3:24
  • 1. Nothing. 2. No, nothing happens. It just stays on the "Unlock phone" prompt. 3. No, I never made a password. – ItsTimmy Jul 21 '15 at 3:30
  • Just asking out of curiosity: have you taken a look at Full Backup of non-rooted devices? – Firelord Jul 21 '15 at 4:53
  • I have now, and I followed exactly the steps of the accepted answer, resulting in the exact same problem as in my original question. – ItsTimmy Jul 21 '15 at 16:03
6

For me force stopping the Facebook Messenger seemed to fix the problem. In your case it might be related to a different app.

Go to Settings->Apps->Select the application you suspect->Press "FORCE STOP"

Possibly this is related to the "draw over other apps" privilege.

Also see http://forums.androidcentral.com/htc-one-s/520618-adb-backup-can-t-click-back-up-my-data-button-phone.html

  • 1
    try adding a picture to the answer to elucidate your point – Tamoghna Chowdhury Oct 28 '15 at 6:41
  • 2
    it was Twilight in my case (paused and it worked) – RumburaK Nov 20 '15 at 22:40
  • I could not press the "Back up my data" button either on a Samsung Galaxy S3. For me I think it was a screen adjuster app that dims the screen. Stopped it after reading the hint here and the button worked. Thanks. – user155187 Mar 8 '16 at 22:31
  • @Lance Which screen adjuster app was it? – Firelord Mar 8 '16 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.