2

Some years ago we bought a Tesco Hudl (the first one, not a Hudl 2). It features a small Tesco button Tesco Navigation Soft Button on the navigation bar. Its presence on the bar is not an issue but there is a problem where the device periodically starts registering presses to this button, opening and closing the Tesco website every few seconds. The only way to stop this at present is to lock the screen using the power button, wait a few seconds, then resume normal use. The manufacturers were clearly aware of screen issues, as one of the software updates that rolled out claimed to address this and did help. The device is so old, it would make no economic sense to physically repair but disabling the button that registers the click would make the user experience much better.

Yesterday I looked around for ways to disable or remove this button. It seems that some years ago people on MoDaCo created a custom firmware for the Hudl that did not have the button. I tried to download the binary last night and the server seemed to through errors, so I assume it does not have the file any more. Further to this the version of firmware this mod seems to apply to the more recent version installed on the Hudl. The Hudl is running Android 4.2.2 and a later ROM version than the 20130923 specified for this alternative image.

A few people also suggesting using some software to remove or disable the soft button without loading a new ROM image. I have managed to ''root'' the Hudl and install the Xposed framework but I have not been able to find a tool that would let me modify the [ T ] softbutton. I have been able to change the style of the other Icons (which might be a welcome relief to my partner as she hates the Lollipop NavBar icons on her Nexus 4), but not alter the Tesco icon.

Please can someone provide some simple instructions of how to remove or disable this NavBar soft button? As I have mentioned it is a rooted Hudl 1, running the latest over-the-air firmware.

1

Well that took quite a bit of work. In the end I was able to get the custom firmware for the Hudl mentioned on the MoDaCo forum. After that the difficulty was getting the USB Drivers up and running to get the Hudl happy as an MTP device. I think this is how it went...

Enable Developer Settings & USB Debugging - This Hudl is an Android 4.2.2 device so you got to Settings > About Device scroll down to Build Number and then tap it 7 times. After that you will find that you can go to Settings > Developer options then enable USB Debugging.

USB Drivers - Honestly I don't know what I did to finally get this working. Even with the Android Development Kit installed the drivers did not load correctly. Some scrabbling around took me to the AndroidCentral Forums from which I downloaded a MotoHelper Driver, extracted the files from that install executable and then installed the 64 bit driver version under \MotoHelper_2.1.32_Driver_5.4.0\$TEMP\ (this took me two attempts). After failing to get an Unknown Device to install as a composite mtp devices, I tried replacing some of the other ones that came up; a Hudl and an MTP device. That did not work so I unplugged the device, plugged it back in. Eventually a second Hudl device appeard and this I could choose to be a Composite MTP which then let adb devices -l see the thing.

Backing-up the old and installing the new SystemUI.apk - This turned out to be the easy bit. Follow the instructions from the MoDaCo forum post. Navigate to wherever you have the new .apk in a console and then: adb pull /system/app/SystemUI.apk SystemUI.mybackup.apk adb push SystemUI.apk /sdcard/SystemUI.apk adb shell su stop mount -o remount,rw /system cp /sdcard/SystemUI.apk /system/app/SystemUI.apk chmod 644 /system/app/SystemUI.apk reboot

I am very grateful to PaulOBrien for getting the modified ROM setup and providing the instructions that got me most of the way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.